Adobe® Acrobat® X Pro Accessibility Guide: Best Practices for PDF Accessibility
For more information
Solution details: www.adobe.com/accessibility/products/acrobat/
Program details: www.adobe.com/accessibility
Contact information: access@adobe.com
PDF Accessibility Overview

Each PDF File is Different

Two Workflows for Creating Accessible PDF Files

Characteristics of Accessible PDF files

Searchable text

Fonts that allow characters to be extracted to text

Interactive form fields

Other Interactive Features: Buttons, hyperlinks, and navigational aids

Document language

Security that will not interfere with assistive technology

Document structure tags and proper read order

Alternative text descriptions

Adobe Acrobat and Adobe Reader Accessibility Features

Features for Accessible Reading of PDFs

Features for Creating Accessible PDFs

The Acrobat X Pro Accessibility Guide Series

PDF Accessibility Overview (this document)

Creating Accessible PDF Documents from Microsoft® Word

Acrobat X Pro PDF Accessibility Repair Workflow

Using the Accessibility Checker in Acrobat X Pro

Creating Accessible PDF Forms with Acrobat X Pro

Acrobat X Pro Complete Best Practices for Accessibility
Acrobat X Pro PDF Accessibility Repair Workflow

Step 1: Examine the PDF File

Step 2: Determine if the PDF is a Scanned Document

How to Tell if a PDF File is a Scanned Document

Note if the page appears to be skewed.

Search for characters that appear on the page.

Zoom in and check for jagged edges on smooth characters.

Use assistive technology or the Read Out Loud feature.

What to Do if the PDF is a Scanned Document

What to Do if the PDF is Not a Scanned Document

Step 3: Add Interactive Features: Form Fields and Buttons

Use Acrobat to Detect and Create Interactive Form Fields

PDF Form Fields

Use Acrobat to Detect and Create Interactive Form Fields

Acrobat Form Wizard

Enter Forms Editing Mode Directly

Create Form Fields Manually

Forms Editing Mode

Creating a New Form Field

Adobe Acrobat X Forms Editing Mode

Form Field Properties

Tooltips for Form Fields

Tooltips for Radio Buttons

Editing or Modifying an Existing Form Field
Deleting a Form Field ................................................................................................................ 24
Buttons ........................................................................................................................................ 24
Set the Tab Order .......................................................................................................................... 24

**Step 4: Add Other Accessibility Features** ................................................................. 25

Document Language .................................................................................................................. 25

To set the language for an entire document: ............................................................................ 25

To set the language for an entire document to a language not in the Language menu: .......... 26

To set the language for individual sections or words: ............................................................ 26

Set Security That Permits Accessibility .................................................................................. 26

Create Accessible Links ............................................................................................................ 27

Add Bookmarks .......................................................................................................................... 28

**Step 5: Determine if the PDF File is a Tagged PDF File** ................................................. 29

View Document Properties. ...................................................................................................... 29

Reveal the Tags Panel. ................................................................................................................. 29

Run the Accessibility Quick Check . ........................................................................................ 31

Quick Check Results .................................................................................................................. 32

Run the Accessibility Full Check. ............................................................................................. 33

Use the TouchUp Read Order Tool (TURO) ........................................................................... 35

What to do if the PDF File is Not Tagged .................................................................................. 36

About the Add Tags Report ....................................................................................................... 37

What to do if the PDF File is Tagged ....................................................................................... 37

**Step 6: Determine if the PDF File is Properly Tagged** .................................................. 38

TouchUp Reading Order Tool (TURO) .................................................................................... 38

Selecting the TouchUp Reading Order Tool ............................................................................ 39
Tips for using the TouchUp Reading Order tool ................................................................. 41

Checking Read Order with the Touch Up Read Order Tool ............................................. 41
  Change the reading order by dragging on the page ...................................................... 42
  Change the reading order using the Order panel ......................................................... 42

Editing Tags with the TouchUp Reading Order Tool ...................................................... 42
  Tag a region ................................................................................................................. 42
  Change the tag for a region ......................................................................................... 43
  Add or remove content from a tagged region .............................................................. 43
  Split a region into two regions ................................................................................... 43
  Apply a heading tag .................................................................................................... 44
  Remove page elements from the tag structure ............................................................ 44
  Apply a figure tag ........................................................................................................ 44

Using TouchUp Reading Order to Check and Correct Figure Tags ................................ 44

Adding Alternate Text with the TouchUp Reading Order Tool ....................................... 45

Using the TouchUp Reading Order Tool Table Editor .................................................. 46
  Add a Table Summary ................................................................................................ 47
  Place the Table in Editing Mode ................................................................................ 47

Remove or Replace Document Structure Tags ............................................................ 50

Replace the Existing Tag Structure on a Page .............................................................. 50

Remove All Tags from a PDF Document ...................................................................... 50

Complex Structures ...................................................................................................... 50
  Content Panel .......................................................................................................... 51

Order Panel .................................................................................................................. 52
  To change the order of content using the Order Panel: ........................................... 53
Tags Panel ................................................................................................................................. 53

Edit tags with the Tags Panel .................................................................................................. 54

Edit a tag title .......................................................................................................................... 55

Move a tag ................................................................................................................................ 55

Change the element type ........................................................................................................... 55

Tags tab options ........................................................................................................................ 56

Add alternate text and supplementary information to tags ........................................................ 57

Add alternate text to links .......................................................................................................... 57

Add alternate text to a figure ...................................................................................................... 57

Add alternate text for an abbreviated term .................................................................................. 57

Create a new child tag ................................................................................................................ 58

Add tags to comments ................................................................................................................ 58

Correct Table Tags with the Tags Tab ....................................................................................... 59

Check table elements ................................................................................................................ 59

Set ColSpan and RowSpan attributes ....................................................................................... 59

Step 7: Use the Accessibility Checker to Evaluate the PDF File ............................................... 60

Accessibility Full Check Options ............................................................................................... 62

Continue Checking Until All Issues are Addressed ................................................................ 63

Additional Validation Techniques ............................................................................................. 63

Acrobat X Pro Accessible Forms and Interactive Documents .................................................. 65

PDF Form Fields ....................................................................................................................... 65

Use Acrobat to Detect and Create Interactive Form Fields ....................................................... 66

Acrobat Form Wizard ................................................................................................................ 66

Enter Forms Editing Mode Directly .......................................................................................... 68

Create Form Fields Manually ................................................................................................... 69

Adobe Acrobat X Accessibility Contents
Forms Editing Mode ................................................................................................................. 69
Creating a New Form Field ........................................................................................................... 70
Adobe Acrobat X Forms Editing Mode ......................................................................................... 71
Form Field Properties .................................................................................................................... 72
Tooltips for Form Fields .............................................................................................................. 72
Tooltips for Radio Buttons ............................................................................................................ 73
Editing or Modifying an Existing Form Field ............................................................................ 75
Deleting a Form Field ..................................................................................................................... 76
Buttons ........................................................................................................................................ 76
Set the Tab Order ............................................................................................................................ 76
Add Other Accessibility Features .................................................................................................. 77
Creating Accessible PDF Files from Microsoft® Word ................................................................. 78
Create an Accessible Microsoft Word Document ....................................................................... 79
Use Styles ...................................................................................................................................... 79
    Text ........................................................................................................................................... 79
    Headings ................................................................................................................................. 79
Columns ........................................................................................................................................ 80
Lists ............................................................................................................................................. 82
Tables .......................................................................................................................................... 83
Links ............................................................................................................................................ 84
Add Alternative Text ..................................................................................................................... 84
    Word 2003 ............................................................................................................................... 84
    Word 2007 ............................................................................................................................... 85
    Word 2010 ............................................................................................................................... 86
Microsoft Word 2010 Accessibility Checker ................................................................. 86
Adobe Acrobat X PDFMaker .................................................................................. 87
Show or activate PDFMaker in Microsoft Word ....................................................... 88
For Office 2003 or earlier, .................................................................................. 88
For Office 2007 .................................................................................................. 88
View PDFMaker conversion settings .................................................................. 89
Settings Tab....................................................................................................... 90
Security Tab ....................................................................................................... 91
Word Tab ........................................................................................................... 92
Bookmarks Tab (Microsoft Word) ....................................................................... 93
Video Tab (Microsoft Word and PowerPoint) ..................................................... 94
PDF Settings for Other Microsoft Office Applications ........................................... 95
Excel-specific options on the Settings tab ............................................................ 95
PowerPoint-specific options on the Settings tab ................................................ 95
Convert the Word Document to Accessible PDF ................................................ 96
Microsoft Office 2003 ....................................................................................... 96
Microsoft Office 2007 ....................................................................................... 96
Microsoft Office 2010 ....................................................................................... 97
If the Word Document is a Form ........................................................................ 98
Check the Resulting PDF With Acrobat X Pro ................................................... 98
Changes to the Conversion Settings .................................................................... 98
Repairs You Should Make in the Source File ....................................................... 99
Repairs You Should Make in the PDF File ........................................................... 99
Document Language .......................................................................................... 99
Tab Order is Consistent with Structure Order ..............................................................................99

Establish Table Headings for Tables ..........................................................................................99

Use Acrobat Action Wizards to Streamline Repetitive Tasks ......................................................100

Using the Acrobat X Pro Accessibility Checker .............................................................................101

Accessibility Quick Check ............................................................................................................101

Quick Check Results ....................................................................................................................102

Full Check .....................................................................................................................................103

Accessibility Full Check Options ..................................................................................................105

Additional Validation Techniques ................................................................................................106
Figure 1. Skewed Text Indicates a Scanned PDF ................................................................. 9
Figure 2. Bitmapped Text Appearance ................................................................................. 10
Figure 3. ClearScan Text Appearance .................................................................................. 10
Figure 4. Scanned Page Alert Dialog .................................................................................. 11
Figure 5. Recognize Text Dialog and Recognize Text Settings ............................................. 12
Figure 6. Create Form Command in the Forms Task Panel.................................................... 14
Figure 7. Acrobat X Pro Create or Edit Form Dialog ........................................................... 15
Figure 8. Adobe Acrobat X Forms Editing Mode .................................................................... 16
Figure 9. Acrobat X Pro Add or Edit Form Fields Dialog .................................................... 17
Figure 10. Adobe Acrobat X Add New Field Command ....................................................... 18
Figure 11. Adobe Acrobat X Forms Tools Icons ................................................................... 18
Figure 12. Adobe Acrobat X Right Click Forms Dialog ....................................................... 19
Figure 13. Field Name Box .................................................................................................... 20
Figure 14. Adding a Tooltip to a Form Field ....................................................................... 21
Figure 15. Identical Button Name and Tool Tip Value for a Radio Button Group .................. 22
Figure 16. Setting One Radio Button in a Group to Indicate "Yes" ....................................... 23
Figure 17. Setting One Radio Button in a Group to Indicate "No" ......................................... 23
Figure 18. Rearranging Tab Order with the Fields Panel ..................................................... 25
Figure 19. Setting the document language ......................................................................... 26
Figure 20. Security Tab Location in Document Properties Dialog ..................................... 27
Figure 21. Password Security Settings .................................................................................. 27
Figure 22. Tagged PDF File Property ................................................................................... 29
Figure 23. No Tags Available in Structure Panel ................................................................. 30
Figure 24. Structure Panel Showing Tags Tree ..................................................................... 30
Figure 25. “Document is Tagged PDF” Indicator in a Structured Document ....................... 31
Figure 26. Acrobat X Pro Accessibility Quick Check Panel .................................................. 32
Figure 27. Acrobat X Pro Accessibility Full Check Panel .................................................... 34
Figure 28. Acrobat X Pro Accessibility Full Check Dialog

Figure 29. Acrobat X Pro Accessibility Report

Figure 30. Displaying the Touch Up Reading Order Tool

Figure 31. Viewing a Tagged Document with the Touch Up Reading Order Tool

Figure 32. Viewing an Untagged Document with the TouchUp Reading Order Tool

Figure 33. Adding Tags to an Untagged PDF File

Figure 34. TouchUp Reading Order Tool

Figure 35. Page Content Display with the TouchUp Reading Order Tool

Figure 36. Add / Edit Alternate Text with TouchUp Reading Order

Figure 37. TouchUp Reading Order Alternate Text Dialog

Figure 38. Using the Order Panel to Activate the Table Editor

Figure 39. Table Editing Mode

Figure 40. Table Cell Properties

Figure 41. Table Editor Options

Figure 42. Set Highlighting On for the Content Panel

Figure 43. Acrobat X Pro Order Panel

Figure 44. Set Content Highlighting On for the Tags Panel

Figure 45. Revealing TouchUp Properties for Tags

Figure 46. Acrobat X Pro Accessibility Full Check Panel

Figure 47. Acrobat X Pro Accessibility Full Check Dialog

Figure 48. Acrobat X Pro Accessibility Report

Figure 49. A Successful Accessibility Check

Figure 50. Create Form Command in the Forms Task Panel

Figure 51. Acrobat X Pro Create or Edit Form Dialog

Figure 52. Adobe Acrobat X Forms Editing Mode

Figure 53. Acrobat X Pro Add or Edit Form Fields Dialog

Figure 54. Adobe Acrobat X Add New Field Command

Figure 55. Adobe Acrobat X Forms Tools Icons
Figure 56. Adobe Acrobat X Right Click Forms Dialog ................................................................. 71
Figure 57. Field Name Box ........................................................................................................ 72
Figure 58. Adding a Tooltip to a Form Field ............................................................................. 73
Figure 59. Identical Button Name and Tool Tip Value for a Radio Button Group ..................... 74
Figure 60. Setting One Radio Button in a Group to Indicate "Yes" ............................................ 75
Figure 61. Setting One Radio Button in a Group to Indicate "No" ............................................... 75
Figure 62. Rearranging Tab Order with the Fields Panel ........................................................... 77
Figure 63. Microsoft Word 2003 Styles and Formatting panel, selected from the Format .......... 79
Figure 64. Microsoft Word 2007 Styles and Formatting ............................................................ 80
Figure 65. Microsoft Word 2010 Styles and Formatting ............................................................ 80
Figure 66. Microsoft Word 2003 Columns ................................................................................. 81
Figure 67. Microsoft Word 2007 Columns ................................................................................. 81
Figure 68. Microsoft Word 2010 Columns ................................................................................. 82
Figure 69. Microsoft Word 2010 List Styles Location ................................................................ 82
Figure 70. Microsoft Word 2010 Table Properties Dialog ....................................................... 83
Figure 71. Microsoft Word 2010 Columns ................................................................................. 84
Figure 72. Microsoft Word 2003 Web Tab for adding Alternative Text ....................................... 85
Figure 73. Microsoft Word 2007 Alt Text for adding Alternative Text ....................................... 85
Figure 74. Microsoft Word 2010 Alt Text dialog for adding Alternative Text ............................ 86
Figure 75. Microsoft Word 2010 Check Accessibility Option .................................................... 87
Figure 76. Microsoft Word 2007 Adobe Acrobat Ribbon and Group ......................................... 88
Figure 77. Change PDFMaker Settings in Word 2003 ............................................................... 89
Figure 78. Acrobat Preferences in Word 2007 ........................................................................... 89
Figure 79. Acrobat Preferences in Word 2010 ......................................................................... 90
Figure 80. PDFMaker Settings Tab .......................................................................................... 91
Figure 81. PDFMaker Security Tab .......................................................................................... 92
Figure 82. PDFMaker Word Tab .............................................................................................. 93
Figure 83. PDFMaker Bookmarks Tab ..................................................................................... 94
Figure 84. PDFMaker Video Tab ........................................................................................................95
Figure 85. Convert to Adobe PDF in Word 2003 .............................................................................96
Figure 86. Create Accessible PDF in Word 2007 ...........................................................................97
Figure 87. Save as Accessible PDF in Word 2007 ..........................................................................97
Figure 88. Create Accessible PDF in Word 2010 ...........................................................................97
Figure 89. Save as Accessible PDF in Word 2010 ..........................................................................98
Figure 90. Acrobat X Pro Accessibility Quick Check Panel .............................................................102
Figure 91. Acrobat X Pro Accessibility Full Check Panel .................................................................103
Figure 92. Acrobat X Pro Accessibility Full Check Dialog ..............................................................104
Figure 93. Acrobat X Pro Accessibility Report ................................................................................104
Figure 94. A Successful Accessibility Check ..................................................................................106
A document or application is accessible if it can be used by people with disabilities—such as mobility impairments, blindness, and low vision—and not just by people who can see well and use a mouse. Accessibility features in Adobe Acrobat, Adobe Reader, and Adobe Portable Document Format (PDF) make it easier for people with disabilities to use PDF documents and forms, with or without the aid of assistive software and devices such as screen readers, screen magnifiers, and braille printers.

Making PDFs accessible tends to benefit all users. For example, the underlying document structure that makes it possible for a screen reader to properly read a PDF out loud also makes it possible for a mobile device to correctly reflow and display the document on a small screen. Similarly, the preset tab order of an accessible PDF form helps all users—not just users with mobility impairments—fill the form more easily.

Each PDF File is Different

Not all PDFs are the same. PDF files are created in a variety of ways, from a variety of applications, and for a variety of purposes. In addition to applying the proper accessibility enhancements to PDF documents, achieving your accessibility goals for an individual PDF file requires understanding the nature of the PDF and the uses for which it is intended.

Using the guide Adobe® Acrobat® X Pro Accessibility Guide: PDF Accessibility Repair Workflow, you will learn how to assess existing PDF files for certain characteristics which influence their accessibility. The order in which this assessment is conducted is important. By following these procedures in the recommended order, users can efficiently proceed through the analysis of a PDF file in a systematic fashion. Systematically ruling out or confirming certain characteristics which a PDF file may possess will guide you to the most appropriate next step for making an individual PDF accessible.

This series also discusses techniques for converting source files to accessible PDF. Using the Adobe PDFMaker with Microsoft Word as an example, this guide provides best practices for designing your source document with accessibility in mind so that the original document can be efficiently transformed into an accessible PDF version. Refer to the guide entitled Adobe® Acrobat® X Pro Accessibility Guide: Creating Accessible PDF from Microsoft® Word for complete information.

Note: These Best Practices techniques assume the user has access to Adobe Acrobat Pro X or Adobe Acrobat X Pro Extended for Windows. Adobe Reader X and Adobe Acrobat X Standard do not have the complete set of tools needed to create and validate PDF documents for accessibility.

Two Workflows for Creating Accessible PDF Files

The PDF format is a destination file format. PDF files are typically created in some other application. What this means is that the author who is concerned with PDF accessibility will be confronted with one of two situations:

- Individuals working with an existing PDF file will want to know how to edit/update it to be an accessible PDF file.
- Authors will want to know how to use some other software application, such as a word processing or desktop publishing application, to generate an accessible PDF file from that application if possible.
Characteristics of Accessible PDF files

The Adobe Portable Document Format (PDF) is the native file format of the Adobe® Acrobat® family of products. The goal of these products is to enable users to exchange and view electronic documents easily and reliably, independently of the environment in which they were created. PDF relies on the same imaging model as the PostScript® page description language to describe text and graphics in a device-independent and resolution-independent manner. To improve performance for interactive viewing, PDF defines a more structured format than that used by most PostScript language programs. PDF also includes objects, such as annotations and hypertext links, that are not part of the page itself but are useful for interactive viewing and document interchange.

Accessible PDFs have the following characteristics:

**Searchable text**

A document that consists of scanned images of text is inherently inaccessible because the content of the document is a graphic representing the letters on the page, not searchable text. Assistive software cannot read or extract the words in a graphic representation, users cannot select or edit the text, and you cannot manipulate the PDF for accessibility. You must convert the scanned images of text to searchable text using optical character recognition (OCR) before you can use other accessibility features with the document.

**Fonts that allow characters to be extracted to text**

The fonts in an accessible PDF must contain enough information for Acrobat to correctly extract all of the characters to text for purposes other than displaying text on the screen. Acrobat extracts characters to Unicode text when you read a PDF with a screen reader or the Read Out Loud tool, or when you save as text for a braille printer. This extraction fails if Acrobat cannot determine how to map the font to Unicode characters.

**Interactive form fields**

Some PDFs contain forms that a person is to fill out using a computer. To be accessible, form fields must be interactive—meaning that a user must be able to enter values into the form fields. Interactive PDF forms also have a defined tab order allowing users of assistive technology to use the tab key in order to progress from one form field or interactive control in a logical manner. Refer to the document Adobe® Acrobat® X Pro Accessibility Guide: Creating Accessible Forms for complete details.

**Other Interactive Features: Buttons, hyperlinks, and navigational aids**

Navigational aids in a PDF—such as links, bookmarks, headings, a table of contents, and a preset tab order for form fields—assist all users in using the document without having to read through the entire document, word by word. Bookmarks are especially useful and can be created from document headings. Many of these aids can be accessed using the keyboard without relying on the mouse.

**Document language**

Specifying the document language in a PDF enables some screen readers to switch to the appropriate language.
Security that will not interfere with assistive technology

Some authors of PDFs restrict users from printing, copying, extracting, adding comments to, or editing text. The text of an accessible PDF must be available to a screen reader. You can use Acrobat to ensure that security settings don’t interfere with a screen reader’s ability to convert the on-screen text to speech.

Document structure tags and proper read order

To read a document’s text and present it in a way that makes sense to the user, a screen reader or other text-to-speech tool requires that the document be structured. Document structure tags in a PDF define the reading order and identify headings, paragraphs, sections, tables, and other page elements.

Alternative text descriptions

Document features such as images and interactive form fields can’t be read by a screen reader unless they have associated alternative text. Though web links are read by screen readers, you can provide more meaningful descriptions as alternative text. Alternative text and tool tips can aid many users, including those with learning disabilities.

Adobe Acrobat and Adobe Reader Accessibility Features

Accessibility features in Adobe Acrobat X and Adobe Reader X fall into two broad categories: features to make the reading of PDF documents more accessible and features to create accessible PDF documents. To create accessible PDF documents, you must use Acrobat, not Reader.

Features for Accessible Reading of PDFs

All versions of Adobe Acrobat X, Adobe Reader X, Acrobat X Standard, Acrobat X Pro, and Acrobat X Suite provide support for the accessible reading of PDF files by persons with disabilities.

• Preferences and commands to optimize output for assistive software and devices, such as saving as accessible text for a Braille printer
• Preferences and commands to make navigation of PDFs more accessible, such as automatic scrolling and opening PDFs to the last page read
• An Accessibility Setup Assistant Wizard for easy setting of most preferences related to accessibility
• Keyboard alternates to mouse actions
• Reflow capability to temporarily present the text of a PDF in a single easy-to-read column
• Read Out Loud text-to-speech conversion.
• Support for screen readers and screen magnifiers

Features for Creating Accessible PDFs

• Creation of tagged PDFs from authoring applications
• Conversion of untagged PDFs to tagged PDFs from within Acrobat
• Security setting that allows screen readers to access text while preventing users from copying, printing, editing, and extracting text

• Ability to add text to scanned pages to improve accessibility

• Tools for editing reading order and document structure

• Tools for creating accessible PDF forms

Though Acrobat Standard provides some functionality for making existing PDFs accessible, you must use Acrobat Pro (also included as part of Acrobat X Suite) to perform certain tasks—such as editing reading order or editing document structure tags—that may be necessary to make some PDF documents and forms accessible (See “Table 1: Features for Creating Accessible PDF Files by Product” on page 3).

Table 1. Features for Creating Accessible PDF Files by Product

<table>
<thead>
<tr>
<th>Feature</th>
<th>Adobe Reader X</th>
<th>Acrobat X Standard</th>
<th>Acrobat X Pro</th>
<th>Acrobat X Suite</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create PDF documents from any application that prints</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Convert Microsoft Word, Excel, PowerPoint, Publisher, and Access files to PDF with one-button ease*</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Capture web pages from Microsoft Internet Explorer and Mozilla Firefox as rich, dynamic PDF files for review and archiving with one-button ease*</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Scan paper documents to PDF and automatically recognize text with optical character recognition (OCR)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Save PDF files as Microsoft Word documents, retaining the layout, fonts, formatting, and tables, to facilitate reuse of content*</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Easily create fillable PDF forms from paper or existing files using the Form Wizard</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Enable users of Adobe Reader® (version 8 or later) to fill in and save PDF forms locally</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Customize Accessibility Preferences with an easy-to-use wizard</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Set high contrast colors for better visibility</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Enable large type display by setting text to reflow through pages</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
</tbody>
</table>
The Acrobat X Pro Accessibility Guide Series

To assist those who use Adobe Acrobat X Pro to create PDF files with the production of content that is accessible to people with disabilities, Adobe Systems has created a series of accessibility guides for Adobe Acrobat X Pro.

PDF Accessibility Overview (this document)

The Adobe® Acrobat® X Pro Accessibility Guide: PDF Accessibility Overview details what is meant by accessibility when considering the PDF file format. It distinguishes between the accessibility features of the the file format and the accessibility features of the Adobe Acrobat X and Adobe Reader application and how the features of the software and the file format interact to achieve accessibility for people with disabilities.

Creating Accessible PDF Documents from Microsoft® Word

The Adobe® Acrobat® X Pro Accessibility Guide: Creating Accessible PDF Documents from Microsoft® Word provides an example using Microsoft Word of how to use Acrobat's PDFMaker to make accessible PDF files from the popular word processing application. Some of the techniques apply to the Microsoft Office productivity suite as well, such as PowerPoint® presentation graphics program.

Acrobat X Pro PDF Accessibility Repair Workflow

The Adobe® Acrobat® X Pro Accessibility Guide: PDF Accessibility Repair Workflow provides a step-by-step method for analyzing existing PDF files and making them accessible based upon that analysis.

Using the Accessibility Checker in Acrobat X Pro

The Adobe® Acrobat® X Pro Accessibility Guide: Using the Accessibility Checker describes the accessibility checkers for PDF files that are included in Adobe Acrobat X Pro. Even if you generate an accessible PDF file from an authoring application such a word processing application or desktop publishing program, you should then follow the steps in this guide in order to identify any items that may have been missed in the initial conversion or to add PDF accessibility features that are not provided by the authoring tool.
Creating Accessible PDF Forms with Acrobat X Pro

The guide entitled Adobe® Acrobat® X Pro Accessibility Guide: Creating Accessible Forms describes how to use the forms tools within Adobe Acrobat X Pro to add descriptions to form fields, tag untagged forms, set the tab order, manipulate tags, and perform other PDF accessibility tasks. These techniques do not apply to PDF forms from Adobe LiveCycle Designer.

Acrobat X Pro Complete Best Practices for Accessibility

The complete content of the individual guides is also available as a single, comprehensive document entitled Adobe® Acrobat® X Pro Accessibility Guide: Best Practices for Accessibility.
Acrobat X Pro PDF Accessibility Repair Workflow

Analyze PDF files and add enhancements to make these documents accessible to all users.

At a high level, the process of making existing PDF files accessible consists of a few basic steps:

1. First, take a moment to examine and evaluate the PDF document before you begin (See “Step 1: Examine the PDF File” on page 7).

2. Determine if the PDF file originated from a scan. If so, perform Optical Character Recognition (OCR) using the OCR Text Recognition command in Adobe Acrobat X (See “Step 2: Determine if the PDF is a Scanned Document” on page 8). If the document is not a scanned image, skip to Step 3 to add any interactive features to your form or document.

3. Add fillable form fields and buttons with short descriptions if the PDF file is intended to function as an interactive document. Set the tab order for the form fields (See “Step 3: Add Interactive Features: Form Fields and Buttons” on page 12). If your PDF document does not have interactive form fields and buttons, then skip to Step 4.

4. Add other accessibility features to the PDF such as bookmarks and set the document security so that it does not interfere with assistive technology (See “Step 4: Add Other Accessibility Features” on page 25).

5. Add tags to the PDF file if it has not been tagged. Tagging generates document structure. This structure is displayed in the Acrobat X Pro Tags Panel as a “structure tree”. The tagging step is introduced at this point in the workflow to ensure that any elements that were added during steps 1 through 4 are included in the structure tree. (See “Step 5: Determine if the PDF File is a Tagged PDF File” on page 29).

6. Determine if the PDF file has been properly tagged. Are the tagged elements properly sequenced? Are tags correctly applied? For example, is a first level heading tagged as an H1 and not an H3? (See “Step 6: Determine if the PDF File is Properly Tagged” on page 38).

7. Check your results with the Acrobat Accessibility Checker. Refer to the results of the Accessibility Report and use the suggestions it offers to make the necessary changes. Repeat this process until the checker indicates no problems are found in the document (See “Step 7: Use the Accessibility Checker to Evaluate the PDF File” on page 60).

Note: These steps are presented in an order that suits most needs most of the time. On occasion, you may perform them in a different order or your workflow and results may require you to repeat some steps until you are satisfied with the results. In all cases, you should first examine the document, determine its intended purpose, and use that analysis to determine the workflow that you should apply.

Step 1: Examine the PDF File

When you open a PDF file in Adobe Acrobat X Pro, take a moment to analyze the document in front of you and note its characteristics.

- Is it a short document with a small number of pages or a long document consisting of many pages?
- Is the document mostly text or a mixture of text and graphics?
• Does the document appear to have form fields?
• Another item to note is the complexity of the document’s layout. In some instances, documents of shorter length may be more challenging when considering accessibility than longer documents because their layout and read order are more complex. Is the layout simple such as in a single column layout with a limited number of graphics, or is it complex with multiple columns, mixed layouts, tables and many graphics? Complex layouts are an indicator that you may be spending more time with the document doing more detailed accessibility enhancements with the Touch Up Read Order Tool.

Step 2: Determine if the PDF is a Scanned Document

A common method for making PDF documents is to place a paper copy of a document into a scanner and then opening the results using Adobe Acrobat to view the newly scanned document as a PDF file. Unfortunately, this process results in creating an image of text and not the actual text itself. This means the content is not accessible to users who rely on assistive technology such as a screen reader to hear the contents of the page. Additional modifications must occur to make the document accessible.

Note: If you are certain that the PDF document is not a scanned document or it has previously undergone optical character recognition, you can skip this discussion and proceed to “Step 3: Add Interactive Features: Form Fields and Buttons” on page 12.

How to Tell if a PDF File is a Scanned Document

There are a number of indications that a PDF file originated from a scanned page. Onscreen, the document appears to contain text, but the page is actually an image. Choose the method that suits you best for determining if the PDF is from a scan and is an “image only” PDF.

Note if the page appears to be skewed.

Sometimes sheets are not properly fed into the scanner. The result being the page appears to be crooked, or skewed on the screen. Lines of text will not be straight but will appear to slant up or down (See “Figure 1. Skewed Text Indicates a Scanned PDF” on page 9).
Search for characters that appear on the page.

Use the find command in Acrobat to search for text that appears on the page. Select Edit > Find (Ctrl + F on Windows or Option + F on Mac OS) and type a term that appears on the page in the search field.

If the document was scanned, Acrobat will not find the search item but will display a message indicating "Acrobat has finished searching the document. No more matches were found".

Zoom in and check for jagged edges on smooth characters.

Scanned images are bitmaps (See "Figure 2. Bitmapped Text Appearance" on page 10). The edges of curves on bit maps will not appear to be smooth or rounded but will be jagged as shown in the sample illustrating the words "Quality" and "region" in Figure 2 on page 10. Use the marquee zoom tool in Acrobat to define the area and magnify the edges of curved letters such as "c", "s", and "o". Text that has undergone the OCR process using the ClearScan option will display smoother edges that are not jagged but are still uneven, or lumpy where there should be smooth curves, as shown in the illustration of the of the words "Quality" and "region" in Figure 3 on page 10.
Use assistive technology or the Read Out Loud feature.

Acrobat X Pro can detect the presence of assistive technology and if it encounters a scanned document will announce an audible empty page warning and display the Scanned Page Alert dialog (See “Figure 4. Scanned Page Alert Dialog” on page 11).
What to Do if the PDF is a Scanned Document

Perform Optical Character Recognition (OCR) to convert the bitmap image of text to actual characters. In Acrobat X Pro. You can do this by selecting "OK" from the Scanned Page Alert dialog (See “Figure 4. Scanned Page Alert Dialog” on page 11). You can also reveal the Recognize Text panel in the Acrobat X Pro Tool Pane.

- View > Tools > Recognize Text
- Use the keyboard accelerator: ALT + V + T + RT

Either of these methods will expose the Recognize Text panel. To display the Recognize Text dialog, select the Recognize Text In This File command in the Tools Pane (See “Figure 5. Recognize Text Dialog and Recognize Text Settings” on page 12). You have the option of scanning the entire document, the current page, or a range of pages within the document. Use the Edit button in the scanned page dialog to set the desired characteristics for the resulting file.

- **Primary OCR Language.** Acrobat does not recognize the language itself, a user must indicate which of the 42 languages is the one to use. Select the language the document appears to be written in.

- **PDF Output Style.** This option should be set to ClearScan. ClearScan will allow the resulting PDF to "reflow". Reflow enlarges the text on the page. As the text size increases, the text wraps so content is not lost in the margins. The other two options, "Searchable Image" and "Searchable Image Exact" will also work with assistive technology but will result in a PDF file that does not reflow.

- **Downsample to.** Downsampling should be set to the lowest downsampling which results in the highest resolution as measured in dots per inch (dpi). This should be 600 dpi.
For additional information on performing optical character recognition using Adobe Acrobat, refer to the Acrobat X Pro Help.

**What to Do if the PDF is Not a Scanned Document**

If the document is not a scanned document, or you have already performed Optical Character Recognition, proceed to the next step, "Step 3: Add Interactive Features: Form Fields and Buttons" on page 12.

**Step 3: Add Interactive Features: Form Fields and Buttons**

Determining if a PDF file is meant to be an interactive form is a matter of visually examining the file and looking for the presence of form fields, or areas in the document where some kind of information is being asked for such as name, address, social security number. Boxes or fields drawn on the page are also typical indications that the document is meant to function as a form. If you want users to be able to complete the form online, rather than resort to printing a paper copy in order to complete the form, then the form is meant to be an interactive form.

---

**Note:** If you are certain the PDF document is not intended to have fillable form fields or buttons, you can skip this discussion and proceed to "Step 4: Add Other Accessibility Features" on page 25.

You can make form fields accessible to vision impaired users and users with mobility challenges by adding fillable fields to the PDF and by properly structuring the form. In addition, you can use the Tooltip field property to provide the user with information about the field or to provide instructions. For example, using the Tooltip property value, the screen reader user would hear "Check this box if you will be attending the luncheon." Without the tool tip property, screen reading software speaks the name of the form field (Check Box 1), its type (Check Box), and its state (Unchecked). It would not be clear to someone listening to the form that they are indicating their desire to attend a luncheon.

You can have Acrobat X Pro detect and create the form fields automatically or you can manually create the necessary fields using Acrobat X Pro's form tools.

This discussion limits itself to the accessibility issues involved with PDF forms created using the Acrobat X Pro forms editing tools. For a more detailed discussion of alternative methods for creating PDF forms, refer to the Adobe Acrobat X Pro Online Help.
Use Acrobat to Detect and Create Interactive Form Fields

When you convert a document to an Acrobat form, Acrobat can detect the form fields in the document. In many instances, Acrobat will use the form field labels to name the field and provide a Tooltip. While the results are often acceptable, this is not a foolproof process. You will need to examine the document carefully to verify that Acrobat accurately detected the fields and labelled them appropriately.

With Adobe Acrobat X Pro, you can make interactive form fields accessible to vision impaired users and users with mobility challenges by adding properly encoded fillable fields to the PDF file. You can also structure the form in such a way that users can use the tab key to move between fields in a meaningful and logical sequence. In addition, entries in the Tooltip field property can provide users of assistive technology, such as screen readers, with additional information about the field or to provide instructions. These tooltips are read by screen readers for the blind and visually impaired.

For example, using the Tooltip property value, you could add text to a check box on an RSVP that users would use to indicate their intention to attend an awards dinner. You can encode the checkbox so the screen reader user would hear “I plan to attend the awards dinner.” Without adding such alternate text to the check box’s tool tip property, a screen reader simply provides the name of the form field (Check Box 1), its type (Check Box), and its state (Unchecked). Screen reader users would hear “Check Box Checked” or “Check Box Unchecked” depending upon whether or not the box had been checked. It would not be clear to users listening to the form with a screen reader that the checkbox indicates their intention to attend the event. This is true even if there is a visible label next to the checkbox which reads, “Check this box if you plan to attend the awards dinner.” You need to add the tooltip text to the checkbox or radio button properties.

Acrobat X Pro can detect and create the form fields automatically or you can manually create the necessary fields using Acrobat X Pro’s form editing tools. If you choose to have Acrobat automatically detect form fields, it will attempt to locate any labels that are adjacent to the form field or check box and use any labels it does find as the source for alternate text (called a tooltip in Acrobat).

Note: This discussion limits itself to the accessibility issues involved with creating form fields with the Acrobat X Pro form tools. For a more detailed discussion of PDF forms including forms created with the Adobe LiveCycle Designer or the Adobe Digital Enterprise Platform Designer, refer to the Acrobat X Pro online help.

PDF Form Fields

A PDF form created with Adobe Acrobat X Pro’s forms editing tools can contain the following types of fields:

- **Text field.** Lets the user type in text, such as name, address, or phone number.
- **Check box.** Presents yes-or-no choices for individual items. If the form contains multiple check boxes, the user can typically select as many or few of these as needed.
- **Radio button.** Presents a group of choices from which the user can select only one item from the group. All radio buttons with the same name work together as a group.
- **List box.** Displays a list of options the user can select. You can set a form field property that enables the user to Shift-click or Control-click to select multiple items on the list.
• **Combo box.** Lets the user either choose an item from a pop-up menu or type in a value.

• **Button.** Initiates a change on the user’s computer, such as opening a file, playing a sound, or submitting data to a web server. These buttons can be customized with images, text, and visual changes triggered by mouse actions. Action buttons have a different purpose than radio buttons, which represent data choices made by the user.

• **Digital signature field.** Lets the user electronically sign a PDF document with a digital signature.

• **Barcode.** Encodes the input form selected fields and displays it as a visual pattern that can be interpreted by decoding software or hardware (available separately).

**Use Acrobat to Detect and Create Interactive Form Fields**

When you convert a document to an interactive form, Acrobat X Pro can detect the form fields in the document. In many instances, Acrobat will use the form field labels to name the field and provide a Tooltip. While the results are often acceptable, this is not a foolproof process. You will need to examine the document carefully to verify that Acrobat accurately detected the fields and labelled them properly.

**Acrobat Form Wizard**

You can use the Form Wizard in Adobe Acrobat X Pro to create interactive forms from a PDF file that is open in Acrobat.

• **Display the Create Command in the Forms Task Panel.** The Forms Task Panel is under the Tools Pane. From the Acrobat X Pro menu, you can select View > Tools > Forms to expose the Forms Task Panel under the Tools Pane (See "Figure 6. Create Form Command in the Forms Task Panel" on page 14). The keyboard accelerator for displaying the Forms Task Panel is Alt + V + T + F.

![Figure 6. Create Form Command in the Forms Task Panel](image)

**Select the Create command (Keyboard Shortcut is Shift + Ctrl + 7).** This displays the Create or Edit Form Dialog (See "Figure 7. Acrobat X Pro Create or Edit Form Dialog" on page 15).
From the Create or Edit Form Dialog, select one of the following options and then follow the on-screen instructions.

- **Use an existing file.** This converts an existing electronic document (for example Word or PDF) to an interactive PDF form. To use the document that is currently on display, select “Next” and “Use the current document.” Select “Next” again. Acrobat automatically searches for and creates any form fields it detects, and places the document in Form Editing Mode. Acrobat informs you that it has entered Form Editing Mode. When you select “OK”, the document is displayed in Form Editing Mode (See “Figure 8. Adobe Acrobat X Forms Editing Mode” on page 16).

- **Scan a paper form.** If you followed the repair workflow procedures in the suggested order, this step is not applicable at this point as optical character recognition was performed in “Step 2: Determine if the PDF is a Scanned Document” on page 8.

- **Create a web form or survey from scratch or template.** This creates an Online Form using Adobe Forms Central. Using Adobe Forms Central is not a topic that is addressed in this Best Practices Guide.

**Note:** Using the Adobe LiveCycle Designer, included in Adobe Acrobat X Pro for Windows, to create accessible PDF forms is not a topic that is addressed in this Best Practices Guide.

Assuming you selected the Use an Existing File option, Acrobat X Pro completes an analysis of the document, adds any form fields it may detect and places the PDF form in Forms Editing Mode. Your document will look similar to what is shown in "Figure 8. Adobe Acrobat X Forms Editing Mode" on page 16. While in Forms Editing Mode, you can add to, edit or delete the automatically created form fields (See "Forms Editing Mode" on page 17).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It may have also created fields of the wrong type. You should verify the fields and field names on the form. You can select Add New Field on the Forms Editing toolbar to add more fields or right click on the form to add, edit, or delete fields.
Enter Forms Editing Mode Directly

If you don't want to use the Form Wizard, you can open the file, and place the document in Form Editing Mode directly.

• **From the Acrobat Menu.** Select View > Tools > Forms and select the Edit command under the Forms Tool Pane (Keyboard shortcut is Shift + Ctrl 7). This displays the Add or Edit Form Fields dialog (See "Figure 9. Acrobat X Pro Add or Edit Form Fields Dialog" on page 17).

Answering "Yes" to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect form fields for you?” results in the automatic detection of form fields prior to placing the document in Form Editing Mode. This is the same as if you had proceeded using the Form Wizard on the current PDF.

Acrobat completes its analysis of the document, adds any form fields it may detect and places the PDF form in Forms Editing Mode where you can edit the automatically created fields or add additional form fields (See “Forms Editing Mode” on page 17).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It may have also created fields of the wrong type. Please verify the fields and field names on your form. You can select Add New Field on the Forms Editing toolbar to add more fields or right click on the form to edit or delete fields.

Answering "No" to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect form fields for you?” also places the document in Form Editing mode, but does not create form fields automatically. You will have to add the form fields manually. Proceed to the next section, “Create Form Fields Manually” on page 5 for further information.
Create Form Fields Manually

To add form fields manually do the following:

- **From the Acrobat Menu.** Select View > Tools > Forms and select the Edit command under the Forms Tool Pane (Keyboard shortcut is Shift + Ctrl 7). This displays the Add or Edit Form Fields dialog (See “Figure 7. Acrobat X Pro Create or Edit Form Dialog” on page 15).

- Select the Edit Command > (Keyboard shortcut is Shift + Ctrl 7) and answer "No" to the question "Do you want Acrobat to detect Form Fields for you?" (See “Figure 7. Acrobat X Pro Create or Edit Form Dialog” on page 15). This places the document in Forms Editing Mode without automatically creating any fields.

- You can now add new form fields to the PDF form by selecting one of the options from the Add New Field Command. This is a drop down menu that presents the 8 Acrobat field types. Proceed to the next section "Forms Editing Mode" on page 17 for further instruction.

**Forms Editing Mode**

With the PDF form in Forms Editing Mode, you can add new fields and buttons to the form and edit or delete any existing field or button. The Acrobat X User Interface changes when in Forms Editing Mode (See “Figure 8. Adobe Acrobat X Forms Editing Mode” on page 16).

- A Forms Editing Toolbar provides access to the Select Object tool, the Add New Field button, and the Form Preview button. You can configure the Add New Field button to display the Forms tools on the toolbar instead of the Add New Field button if you prefer.

- On the right hand side of the Forms Editing Toolbar, beneath the Tasks pane, the Add New Field Command, Distribute Command, Track Command, Close Form Command, and Other Tasks Command are displayed under the Tasks panel.

- A fields panel appears below the Tasks panel showing any interactive fields that are currently part of the form.

**Creating a New Form Field**

In Acrobat X Pro, you create a form field by choosing one of the form tools. For each field type, you can set a variety of options through the form field Properties dialog box.

You can access the forms tools one of three ways.
• You can select "Add New Field" under the task panel (See “Figure 10. Adobe Acrobat X Add New Field Command" on page 18).

![Adobe Acrobat X Add New Field Command](image1)

Figure 10. Adobe Acrobat X Add New Field Command

• You can select one of the Forms Tools icon from the Forms Tool Bar that appears below the Acrobat X Pro menu bar (See “Figure 11. Adobe Acrobat X Forms Tools Icons” on page 18).

![Adobe Acrobat X Forms Tools Icons](image2)

Figure 11. Adobe Acrobat X Forms Tools Icons

• You can right click over the form to present options that allow you to add, edit, or delete fields (See “Figure 12. Adobe Acrobat X Right Click Forms Dialog” on page 19).
Adobe Acrobat X Forms Editing Mode

Once you have selected a form tool, the cursor becomes a cross hair and a light blue region defines the outline of the form object you have selected for placement.

- On the page, click where you want to add the field to create a field with the default size. To create a field using a custom size, drag a rectangle to define the size of the field.

- In the Field Name box, type the name of the field, if you want to change it from the default name that Acrobat provides. Acrobat provides a default name based upon the field type and the number of fields drawn on the page. You should choose a name that is relevant and descriptive to make organizing and collecting the data easier (See "Figure 13. Field Name Box" on page 20).

- At this point you can also specify if you want the field to be a required field. To display the Properties dialog box and modify any other field properties, click Show All Properties (See “Figure 13. Field Name Box” on page 20).

Note: If you have checked the "Keep Tool Selected" option in the forms toolbar, the Field Name box doesn’t appear after adding a field. Each time you click the page, a new field is added to the form. To exit this mode, press the Esc key or click the Select Object Tool button. To modify the properties of the field, double-click the field.
To test your form, click the Preview button at the top of the document window. Previewing a form allows you to view the form the same way the form recipients will see it and gives you a chance to verify the appearance and behavior of the form. If you are previewing a form, you can click the Edit Layout button to return to Forms Editing mode.

**Form Field Properties**

How a form field behaves is determined by settings in the Properties dialog box for that individual field. You can set properties that apply formatting, determine how the form field information relates to other form fields, impose limitations on what the user can enter in the form field, trigger custom scripts, and so forth.

You can set a variety of properties for an Acrobat form field, depending on the form field type. The properties for each type of form field are selected on a series of tabs. When you change a property, it is applied as soon as you select another property or press Enter.

All the form field types have a General tab, Appearance tab, and an Actions tab. Other tabs appear only in specific types of form fields. The Options tab appears for most form field types but the options available are unique to each type of form field.

If you are changing the properties of multiple fields, you can leave the Properties dialog box open. Click on each field to change its properties.

**Tooltips for Form Fields**

For accessibility, the Tooltip option on the General tab is important for entering text that will be announced by screen readers.

You can make form fields accessible to people with disabilities by adding tags to the PDF and by properly structuring it. In addition, you can use the tool tip form field property to provide the user with information about the field or to provide instructions. For example, using the tool tip property value, the screen reader could say "Your first name." Without the tool tip property, a screen reader announces the type and name of the form field (See "Figure 14. Adding a Tooltip to a Form Field" on page 21).

- If necessary, choose Forms > Add or Edit Fields, and make sure that the Select Object tool is selected.
- Double-click a selected form field to open the Properties window.
- In the General tab, type a description into the tool tip box.
The Tooltip also displays text that users may find helpful in filling in the form field. Tooltips appear when the pointer hovers briefly over the form field.

![Figure 14. Adding a Tooltip to a Form Field](image)

**Tooltips for Radio Buttons**

To create a set of mutually exclusive Radio Buttons, where only one field can be selected at a time, give each field the same name and the same Tooltip, but different Button values. The Button value is a field in the options tab of the Radio Button Properties dialog.

To make a radio button accessible, in addition to entering unique text in the Button Value field for each choice, you would enter identical text in the Tooltip field of the General properties tab for each radio button in the group (See "Figure 15. Identical Button Name and Tool Tip Value for a Radio Button Group" on page 22).

For example, you may need to create a radio button group that asks the question, “Do You Need a Hotel Room Reservation?”

- You would create two radio buttons. For each button, you might choose to give the button the identical name, “Hotel Reservation.” For each button, you would enter identical text in the Tooltip field, such as “Do You Need a Hotel Room Reservation?” (See “Figure 15. Identical Button Name and Tool Tip Value for a Radio Button Group” on page 22).
For the button next to the label indicating Yes, you would enter “Yes” in the Button Value field under the options tab (See “Figure 12. Adobe Acrobat X Right Click Forms Dialog” on page 19). For the other, the one next to the No label, you would enter “No” in the Button Value field (See “Figure 16. Setting One Radio Button in a Group to Indicate “Yes”” on page 23).
Editing or Modifying an Existing Form Field

You can access Acrobat form field properties only when you are in editing mode (by choosing Forms > Add Or Edit Fields). You can change the properties for multiple form fields at a time.

Open the Properties dialog box using one of the following methods:

- To edit a single form field, double-click it or right-click/Control-click it and choose Properties.
- To edit multiple form fields, select the fields that you want to edit, right-click/Control-click one of the selected fields, and choose Properties.

Change the properties on each of the available tabs, as needed. The property is changed as soon as you select another property or press Enter.

- Click Close to close the Properties dialog box.

If you select form fields that have different property values, some options in the Properties dialog box are not available. Otherwise, changes to the available options are applied to all selected form fields.
To avoid accidental changes to the form field, select Locked in the lower left corner of the Properties dialog box before you close it. To unlock, click the check box again.

Deleting a Form Field

With the document in Forms Editing mode, click on the field you would like to delete and do any of the following.

- Right mouse click and select delete
- Press the delete key.
- From the menu, select Edit > Delete (ALT + ED)

Note: You can select multiple fields by holding the Control key as you click on each one.

Buttons

Buttons are most commonly associated with forms, but you can add them to any document. Buttons can open a file, play a sound or movie clip, submit data to a web server, and much more. When deciding on how to initiate an action, remember that buttons offer the following capabilities that links and bookmarks do not:

- A button can activate a single action or a series of actions.
- A button can change appearance in response to mouse actions.
- A button can be easily copied across many pages.
- **Mouse actions can activate different button actions.** For example, Mouse Down (a click), Mouse Up (releasing after a click), Mouse Enter (moving the pointer over the button), and Mouse Exit (moving the pointer away from the button) can all start a different action for the same button.

Buttons are an easy, intuitive way to let users initiate an action in PDF documents. Buttons are added the same way as form fields while in Forms Editing mode. They also should be given a name and a Tooltip and their behavior is determined by the actions the user assigns the button on the actions tab of the Button Properties dialog. They also appear in the Tab order tree. See the Adobe Acrobat Help for a complete discussion of PDF fields and buttons.

Set the Tab Order

If a PDF document doesn't have a specified tab order, the default tabbing order is based on the document structure unless the user has deselected the Tab Order option in the Accessibility preferences.

You can change the tabbing order after you create the fields.

- If you are in Forms Editing mode, you can order the tabs by document structure (default), row, or column.
- You can also choose the order manually by dragging and dropping fields in the Fields panel.
- If you are not in Forms Editing mode, you can change the page properties to order the tabs by row or column. However, you can't customize the tab order manually.
To change the tab order, first select “Order Tabs Manually” from the Tab Order button on the Fields panel. Then you can drag and drop fields where you want them within the Fields panel to modify the tab order (See “Figure 18. Rearranging Tab Order with the Fields Panel” on page 25). To assist in determining tab order, you can select “Show Tab Numbers” from the Tab Order button of the Fields panel (See “Figure 18. Rearranging Tab Order with the Fields Panel” on page 25).

In the example shown in Figure 18 on page 25, Text Field 1 “District” is in the second position though it should be first. Text Field 2, “Date Due” is in the first position, though it should be second. Selecting the entry for Text2 in the Forms panel highlights the corresponding field in the document view. To move it to the second position, drag it down and drop it below the entry for Text1 (or you could pushed Text1 up above Text2). Refer to “Figure 18. Rearranging Tab Order with the Fields Panel” on page 25 to see the relationship between items in the Fields Panel and the Document pane. Note also the Order Tabs Manually and the Show Tab Numbers options are highlighted.

![Figure 18. Rearranging Tab Order with the Fields Panel](image)

**Step 4: Add Other Accessibility Features**

This stage includes setting the document language, making sure that security settings do not interfere with screen readers, creating accessible links, and adding bookmarks.

**Document Language**

Setting the document language in a PDF enables some screen readers to switch to the appropriate language. You can set the document language for an entire document with Acrobat Pro, Acrobat Pro Extended, or Acrobat Standard. You can set the document language for specific portions of a multilanguage document with Acrobat Pro or Acrobat Pro Extended (See “Figure 19. Setting the document language” on page 26).

**To set the language for an entire document:**

- Choose File > Properties, (Cntrl + D for Windows, Cmnd + D Mac OS) and select a language from the Language menu in the Reading Options area of the Advanced tab.
To set the language for an entire document to a language not in the Language menu:

- Choose File > Properties (Ctrl + D for Windows, Cmd + D Mac OS), and enter the ISO 639 code for the language in the Language field in the Reading Options area of the Advanced tab. For more information, see the ISO Language Codes on http://www.loc.gov/standards.

To set the language for individual sections or words:

- Select the desired text element in the Tags tab and right click.
- Choose Properties from the Options menu. In the TouchUp Properties dialog box, select the Tag tab. Select a language from the Language menu, and click Close.

Note: The language that you specify for an element also applies to all elements nested under it in the logical structure tree.

---

**Figure 19. Setting the document language**

**Set Security That Permits Accessibility**

You should ensure the Acrobat X security settings permit access to the document by assistive technology. You can verify the Acrobat X or Adobe Reader 9 security settings do not prohibit access to assistive technology by checking the security preferences tab of the document properties dialog.

- Select File > Properties (Ctrl + D for Windows, Cmd + D Mac OS)
- Select the Security Tab of the Document Properties dialog (See "Figure 20. Security Tab Location in Document Properties Dialog" on page 27)
With thoughtfully provided links, users can quickly move from one part of a document to another, to related information in a different document, or to a website that is relevant to the content.

For URLs to be accessible to screen readers, you must convert them to active links and make sure that they are correctly tagged in the PDF.
Acrobat provides several ways to create active links for text, objects, and URLs in a PDF. However, the methods differ in how they affect the tag tree. The best way to create accessible links is with the Create Link command.

Unlike the other methods for creating links in a tagged PDF (by using the Links tool or the Create From URLs In Document command), the Create Link command adds all three tags that screen readers require in order to recognize a link. The other methods create only one of the three tags, meaning that you must manually edit the tag tree to add the remaining two tags for each link and place these tags in the proper reading order in the tree. Although you must activate links one by one, using the Create Link command provides the fastest results and the least amount of follow-up work to make the links accessible to screen readers. All that is left to do is optional editing of the tag tree to add alternate text to the new links.

Creating links with Acrobat Standard doesn’t generate any tags for the links.

Do the following to make links active and add them to the tag tree:

- Select the text or object for which you want to create a link.
- Right-click the selection, and choose Create Link from the context menu.
- In the Create Link dialog box, select the appropriate options, and then follow the on-screen instructions to specify a URL, page view, or file as the link target.

By default, the selected text for each link becomes the link text. After you add all the links, you can edit the tag tree to add alternate text to the links, further improving the accessibility of the PDF.

Add Bookmarks

A bookmark is a type of link with representative text in the Bookmarks panel in the navigation pane. Each bookmark goes to a different view or page in the document. Bookmarks are generated automatically during PDF creation from the table-of-contents entries of documents created by most desktop publishing programs. These bookmarks are often tagged and can be used to make edits in the PDF.

Initially, a bookmark displays the page that was in view when the bookmark was created, which is the bookmark’s destination. In Acrobat, you can set bookmark destinations as you create each bookmark. However, it is sometimes easier to create a group of bookmarks, and then set the destinations later.

In Acrobat, you can use bookmarks to mark a place in the PDF to which you want to return, or to jump to a destination in the PDF, another document, or a web page. Bookmarks can also perform actions, such as executing a menu item or submitting a form.
Step 5: Determine if the PDF File is a Tagged PDF File

Tagging is essential for PDF accessibility, it is used to establish logical read order and to provide hooks for adding alternative text descriptions to non-text elements that are in the PDF document.

If you have been following the workflow up to this point, you will have a PDF file that is searchable because you performed optical character recognition on a scanned document, or it was searchable to begin with. You have also added any desired interactivity in the form of navigational controls or interactive form fields. At this point it may or may not be a tagged PDF file.

There are several ways to determine if a PDF file has been tagged.

View Document Properties.

File > Properties (Ctrl +D) - In the lower left hand corner of the Description tab, is an indication as to whether or not the document is tagged (See "Figure 22. Tagged PDF File Property" on page 29).

Reveal the Tags Panel.

Select View > Show/Hide > Navigation Panes > Tags from the Acrobat X Pro menu (Keyboard Accelerator is Alt V + S + N + G). An untagged document will display the words “No Tags Available” as its root and there will be no visible “structure tree” descending from the root (See...
A tagged document will show tags and a structure tree descending from the root node. To expand the entire tree fully, Cntrl + click on the root node labelled “Tags” (See “Figure 24. Structure Panel Showing Tags Tree” on page 30).

In some cases, a document may not be considered tagged by Acrobat even though a structure is visible in the Tags panel. Select the tags options icon and ensure a check mark appears before the entry "Document is Tagged PDF." If it does not, simply select this entry to add the missing check mark (See “Figure 25. "Document is Tagged PDF" Indicator in a Structured Document” on page 31).
Run the Accessibility Quick Check.

Use Quick Check to check for document structure tags, searchable text, and appropriate security settings for accessibility. This method is often the best way to check for accessibility before attempting to use a PDF.

Note: The Accessibility Quick Check is also available for Adobe Reader X and Adobe Acrobat X Standard.

- **Adobe Reader X Accessibility Quick Check.** In Adobe Reader X, the Accessibility Quick Check is run by selecting Edit > Accessibility > Quick Check from the Adobe Reader menu. The keyboard accelerator is Alt+E+Y+Q. The keyboard shortcut is Shift + Ctrl + 6.

- **Adobe Acrobat X Pro Accessibility Quick Check.** In Adobe Acrobat Pro X, you must first reveal the Accessibility Tool pane. If it is not already displayed, select View > Tools > Accessibility from the Adobe Acrobat X Pro menu. The keyboard accelerator is Alt+V+T+A.
  - With the Accessibility Tool Pane revealed, you can select the Quick Check panel. (See “Figure 26. Acrobat X Pro Accessibility Quick Check Panel” on page 32).
  - The keyboard shortcut Shift + Ctrl + 6 runs the Accessibility Quick Check immediately without having to select the Quick Check panel from the Accessibility Tool pane.
Quick Check Results

The Quick Check will generate one of the following messages when reporting results to the user depending upon which accessibility features are present in the file.

• **This document has logical structure but it is not a Tagged PDF.** Some accessibility information may be missing." Quick Check has found an underlying document structure in the document, so Acrobat will use the available document structure to control the reading order, rather than analyzing the document itself. However, this untagged document structure might be incomplete or unreliable, so assistive software and the accessibility features in Acrobat (such as the Read Out Loud and the Save As Text features) may not read the page properly. If the reading order of the page seems to be wrong, select Override The Reading Order In Tagged Documents in the Reading panel of the Preferences dialog box.

Another cause for this error is the Document is Tagged PDF option is not checked. In some cases, a document may not be considered tagged by Acrobat even though a structure is visible in the Tags panel. Select the tags options icon and ensure a check mark appears before the entry “Document is Tagged PDF.” If it does not, simply select this entry to add the missing check mark (See “Figure 25. “Document is Tagged PDF” Indicator in a Structured Document” on page 31).

• **This document is not structured, so the reading order may not be correct. Try different reading orders using the Reading Preferences panel.** Quick Check has found no underlying document structure that Acrobat can use for reading order. Acrobat will analyze the reading order of the document using the current analysis method set in the Reading Order preference, but this PDF might not be read correctly by screen readers. If the reading order seems wrong, select a different option for Reading Order in the Reading panel of the Preferences dialog box.

• **No accessibility problems were detected in this quick check. Choose the Full Check command to check more thoroughly.** Quick Check has found that the PDF contains searchable text, is tagged, has an underlying document structure, and has no security settings that prohibit access for screen readers. To check for other types of accessibility problems that may be present in the PDF, use Full Check.
• **This document’s security settings prevent access by screen readers.** Quick Check has found that the PDF has security settings that interfere with screen readers’ ability to extract text for conversion to speech. You may be able to use a screen reader with this document if your assistive technology product is registered with Adobe as a Trusted Agent. Contact your assistive technology product vendor.

• **This document appears to contain no text. It may be a scanned image.** Quick Check has found that the PDF contains no searchable text, probably because the document consists entirely of one or more scanned images. This means that screen readers, Read Out Loud, Reflow view, and most other accessibility features—which rely on text as input—will not work with this document.

**Run the Accessibility Full Check.**

Use Full Check to perform a more thorough check for many characteristics of accessible PDFs, including missing tags.

Full Check checks a PDF for many of the characteristics of accessible PDFs including looking for the presence of tags.

You can choose which kinds of accessibility problems to look for and how you want to view the results. To run the full Accessibility Check, do the following:

• In Adobe Acrobat Pro X, you must first reveal the Accessibility Tool pane. If it is not already displayed, select View > Tools > Accessibility from the Adobe Acrobat X Pro menu. The keyboard accelerator is Alt+V+T+A.

• With the Accessibility Tool Pane revealed, you can select the Full Check panel (See "Figure 27. Acrobat X Pro Accessibility Full Check Panel" on page 34).

• Selecting the Full Check panel brings up the Accessibility Full Check dialog (See "Figure 28. Acrobat X Pro Accessibility Full Check Dialog" on page 34).

• You can save the results as an HTML file or as comments that are located where the accessibility problems are detected.

• Select a page range if you prefer to do a full check on individual sections of a document.

• Select an accessibility standard (Adobe PDF, Section 508 (U.S.), or W3C) from the Name menu, and then select the accessibility options to check for.

• Select Start Checking.
The results are displayed in the left panel, which also has helpful links and hints for repairing issues (See “Figure 29. Acrobat X Pro Accessibility Report” on page 35). If you created a report in step 2, the results are available in the selected folder. Clicking on the links highlights the problem areas in the document. The Accessibility Checker panel also provides hints for repair which you should follow. For a complete discussion of the Accessibility Full Check (See “Step 7: Use the Accessibility Checker to Evaluate the PDF File” on page 60).
In the instance where the document is missing tags, the error message Acrobat displays reads, “This document is not tagged; the reading order of the contents may be incorrect. This is followed by a link providing information on “How to Add Tags.”

Figure 29. Acrobat X Pro Accessibility Report

**Use the TouchUp Read Order Tool (TURO)**

Another way to check for the presence of tags is to display the TouchUp Reading Order Tool or TURO. To display the TouchUp Reading Order Tool, if the Accessibility panel is not already on display, select View > Tools > Accessibility from the Adobe Acrobat X Pro menu. Then select the TouchUp Reading Order command under the Accessibility panel (See “Figure 30. Displaying the Touch Up Reading Order Tool” on page 35).

A tagged document will display shaded areas on the page that are numbered (See “Figure 31. Viewing a Tagged Document with the Touch Up Reading Order Tool” on page 36). An untagged document will not display these numbered rectangles (See “Figure 32. Viewing an Untagged Document with the TouchUp Reading Order Tool” on page 36).

Figure 30. Displaying the Touch Up Reading Order Tool
What to do if the PDF File is Not Tagged

If the file has not been tagged. You can add tags to the document using Adobe Acrobat X Pro. There are two ways to do this. With the tags panel open you can select "Add Tags to Document" from the Options button in the Tags panel, or with the Accessibility Panel open in the Tools Pane, you can select the "Add Tags to Document" command (See "Figure 33. Adding Tags to an Untagged PDF File" on page 37).
About the Add Tags Report

If Acrobat encounters potential problems while running the Add Tags To Document command, the Add Tags Report opens in the navigation pane. The report lists potential problems by page, provides a navigational link to each problem, and offers suggestions for fixing them. It is similar to the Accessibility Report that is produced when you run an accessibility full check as described in "Step 7: Use the Accessibility Checker to Evaluate the PDF File" on page 60.

You could choose to repair the problems at this time by following the suggestions in the Add Tags report or now that the file is tagged proceed to the next step "Step 6: Determine if the PDF File is Properly Tagged" on page 38.

If you choose to repair the document at this stage, remember to assess the context of any error before following a particular suggestion for fixing it. For example, the report might state that an element has been tagged as a figure and requires alternate text to make it accessible. When you examine the figure in its context on the page, you may decide that the figure is a background design element, not an illustration that conveys valuable meaning to the user. In the case of a nonessential image, you would change the Figure tag to a Background tag; in the case of an image intended to convey meaning to the reader, you would add alternate text.

Note: The Add Tags Report highlights tagging-related problems only, and it is a temporary file that you cannot save. You can assess other tagging, reading order, and accessibility problems by using Full Check.

If adding tags to a PDF in Adobe Acrobat results in a tagging structure that is overly complicated or too problematic to fix, you can use the TouchUp Reading Order tool to remove or replace the current structure. If the document contains mostly text, you can select a page and then remove headings, tables, and other elements to create a cleaner, simpler tagging structure (See "Step 6: Determine if the PDF File is Properly Tagged" on page 38).

What to do if the PDF File is Tagged

If the PDF file appears to be tagged, proceed to the next step, "Step 6: Determine if the PDF File is Properly Tagged" on page 38.
Step 6: Determine if the PDF File is Properly Tagged

A quick way to determine if the PDF file has been properly tagged is to use the TouchUp Reading Order Tool (See “Figure 34. TouchUp Reading Order Tool” on page 39).

The Touch Up Reading Order Tool divides a tagged page into shaded segments. Each segment is numbered indicating the read order of the item on the page. You can also verify the read order of items on the page by displaying the order panel from the Touch Up Read Order Tool.

Note: If you are certain the PDF document is properly tagged, you can skip this discussion and proceed to “Step 7: Use the Accessibility Checker to Evaluate the PDF File” on page 60.

TouchUp Reading Order Tool (TURO)

The TouchUp Reading Order tool provides the easiest and quickest way to fix reading order and basic tagging problems. When you select the TouchUp Reading Order tool, a dialog box opens that lets you see overlay highlights that show the order of page content. Each highlighted region is numbered and highlighted with gray or colored blocks; the number indicates the region's placement in the page's reading order. After you check the reading order of the page, you can correct other, more subtle tagging issues as needed.

Note: The TouchUp Reading Order tool is intended for repairing PDFs that were tagged using Acrobat, not for repairing PDFs that were tagged during conversion from an authoring application. Whenever possible, you should return to the source file and add accessibility features in the authoring application. Repairing the original file ensures that you don't have to repeatedly touch up future iterations of the PDF in Acrobat.

You use the TouchUp Reading Order tool to perform the following accessibility tasks:

- Visually check, and then repair, the reading order of page content
- Tag fillable form fields and their labels
- Add alternative text to figures and descriptions to form fields
- Fix the tagging of simple tables, and prepare complex tables for more advanced manipulation in the logical structure tree
- Remove nonessential content, such as ornamental page borders, from the logical structure tree
Selecting the TouchUp Reading Order Tool

To display the TouchUp Reading Order Tool, if the Accessibility panel is not already on display, select View > Tools > Accessibility from the Adobe Acrobat X Pro menu. Then select the TouchUp Reading Order command under the Accessibility panel (See “Figure 30. Displaying the Touch Up Reading Order Tool” on page 35).

When you select TouchUp Reading Order, a dialog box opens that lets you see overlay highlights that show the order of page content (See “Figure 35. Page Content Display with the TouchUp Reading Order Tool” on page 39).

Each highlighted region is numbered and highlighted with gray or colored blocks; the number indicates the region's placement in the page's reading order.
TouchUp Reading Order Tool Options

You can select TouchUp Reading Order options from the dialog box, from the pop-up menu that appears when you right-click a highlighted region, or from the Options menu in the Order tab. The TouchUp Reading Order tool includes the following options:

- **Text**. Tags the selection as text.

- **Figure**. Tags the selection as a figure. Text contained within a figure tag is defined as part of the image and is not read by screen readers.

- **Form Field**. Tags the selection as a form field.

- **Figure/Caption**. Tags a selected figure and caption as a single tag. Any text contained in the tag is defined as a caption. Useful for tagging photos and captions and preventing caption text from being incorrectly added to adjacent text blocks. Figures may require alternate text.

- **Heading 1, Heading 2, Heading 3**. Tags the selection as a first, second, or third level heading tag. You can convert heading tags to bookmarks to help users navigate the document.

- **Table**. Tags the selection as a table after the selection is analyzed to determine the location of headings, columns, and rows.

- **Cell**. Tags the selection as a table or header cell. Use this option to merge cells that are incorrectly split.

- **Formula**. Tags the selection as a formula. Because speech software may handle formula tags differently from normal text, you may want to add a description using alternate text.

- **Background**. Tags the selection as a background element, or artifact, removing the item from the tag tree so that it doesn’t appear in the reflowed document and isn’t read by screen readers.

- **Table Editor**. Automatically analyzes the selected table into cells and applies the appropriate tags. The table must be tagged as a table before you can use the Table Editor command on it.

- **Show Page Content Order**. Shows content elements as highlighted areas that contain numbers to indicate the reading order. The rectangle next to this entry is a color swatch. Specify the desired highlight color for page content order by clicking the color swatch.

- **Show Table Cells**. Highlights the content of individual table cells. The rectangle next to this entry is a color swatch. Specify the highlight color for Table Cells by clicking the color swatch.

- **Show Tables And Figures**. Outlines each table and figure with a crossed-out box. The box also indicates whether the element includes alternate text. The rectangle next to this entry is a color swatch. Specify the highlight color for Tables and Figures by clicking the color swatch.

- **Clear Page Structure**. Removes the tagging structure from the page. Use this option to start over and create a new structure if the existing structure contains too many problems.

- **Show Order Panel**. Opens the Order tab to allow you to reorder highlighted content.
- **Edit Alternate Text**. Available in the menu that appears when you right-click a highlighted figure. Allows the user to add or edit a text description about the figure properties that is read by a screen reader or other assistive technology.

- **Edit Form Field Text**. Available in the menu that appears when you right-click a form field. Allows the user to add or edit a form field text description that is read by a screen reader or other assistive technology.

- **Edit Table Summary**. Available in the menu that appears when you right-click a highlighted table. Allows the user to add or edit a text description about the table properties that is read by a screen reader or other assistive technology.

**Tips for using the TouchUp Reading Order tool**

When using the TouchUp Reading Order tool, you should be mindful of the following tips for use:

- Save the document (or a copy of it) before you use the TouchUp Reading Order tool. You can’t use Undo to reverse changes made with this tool, so reverting to a saved document is the only way to undo such a change.

- Choose View > Page Display > Single Page, when using the TouchUp Reading Order tool. When you click the Clear Structure button, Acrobat clears tags from all visible pages—even pages that are only partially visible.

**Checking Read Order with the Touch Up Read Order Tool**

You can quickly check the reading order of tagged PDFs by using the TouchUp Reading Order tool. You can also use this tool to add alternate text to images and correct many types of tagging problems that are outlined in the report that Acrobat generates when you add tags to a PDF.

Reading-order problems are readily apparent when you use the TouchUp Reading Order tool. Each section of contiguous page content appears as a separate highlighted region and is numbered according to its placement in the reading order.

Within each region, text is ordered left to right and top to bottom. (You can change this order in the TouchUp preferences.) If a single highlighted region contains two columns of text or text that won’t flow normally, divide the region into parts that can be reordered. Because highlighted regions are rectangular, they may overlap somewhat, especially if their page content is irregularly shaped. Unless page content overlaps or is contained within two highlighted regions, no reading order problem is indicated. Page content should belong to no more than one highlighted region.

You can change the reading order of the highlighted regions by moving an item in the Order Panel or by dragging it on the page in the document pane. By reordering highlighted regions on the page, you can make a figure and caption read at the specific point that they are referenced in the text. By changing the order of a highlighted region, you effectively change the reading order of that item without changing the actual appearance of the PDF.

To check the reading order with the TouchUp Reading Order tool:

- Select the TouchUp Reading Order tool.

- In the TouchUp Reading Order dialog box, select Show Page Content Order.

---

**Note:** If highlighted regions don’t appear in the document pane, the document doesn’t contain tags. You will need to add tags to the document (See "Step 5: Determine if the PDF File is a Tagged PDF File" on page 29).
You may modify the view of the page by doing any of the following:

- To specify a highlight color, click on one of the color swatches, the small squares to the right of the check boxes for "Show page content order", "Show table cells" and "Show tables and figures." Select the color you want from the swatch that pops up.

- To highlight tables and figures, and to view alternate text for figures, select Show Tables And Figures.

- Check the reading order of text within each highlighted region. Zooming in can make this step easier.

- Check the numbered order of all highlighted regions. If consecutive, numbered regions don't follow one another, reorder them in the Order tab.

- Click Show Order Panel, and then select each content entry (in square brackets [ ]) in the Order tab to highlight that content region in the document pane. Use this method to find numbered regions that you can't see or locate on the page.

**Change the reading order by dragging on the page**

- Select the TouchUp Reading Order tool.

- In the TouchUp Reading Order dialog box, select Show Page Content Order.

- In the document pane, place the pointer over the number for the highlighted region you want to move, and drag it to where you want it to be read. The text-insertion pointer shows target locations within the text.

**Change the reading order using the Order panel**

- Select the TouchUp Reading Order tool.

- In the TouchUp Reading Order dialog box, click Show Order Panel.

- In the Order tab, navigate to view a list of highlighted regions that appear in the document pane.

- Push items up or drag them down to rearrange their order.

**Editing Tags with the TouchUp Reading Order Tool**

You can use the TouchUp Reading Order tool to create tags in untagged PDFs or to add new tags to an existing structure. However, this manual tagging doesn't provide the same level of detail to the tagging structure as the Add Tags To Document command, such as paragraphs, bulleted and numbered lists, line breaks, and hyphens. Before you clear the existing structure, make sure that manual tagging is your only recourse.

**Tag a region**

Using the TouchUp Reading Order tool, drag within the document pane to select a region of the page that contains one type of content (for example, a text block).

Do one of the following:

- To add more page content to the current selection, Shift-drag.

- To remove page content from the current selection, Ctrl-drag/Command-drag.
Click the appropriate button in the TouchUp Reading Order dialog box to specify the tag type.

**Change the tag for a region**

If Acrobat tags a page element incorrectly, you can change the tag type for the highlighted region.

- Select the TouchUp Reading Order tool.
- In the TouchUp Reading Order dialog box, select Show Page Content Order.

To select a highlighted region, do one of the following:

- Drag to select it.
- Click the number of a highlighted region.
- Click the button for the tag type that you want the highlighted region to be.

**Add or remove content from a tagged region**

The TouchUp Reading Order tool always displays as few highlighted regions as possible. If content within a highlighted region doesn’t flow properly, you may need to split a region to reorder it. Highlighted regions may also contain adjacent page content that is unrelated or that requires a different tag type. Page content may become orphaned from related elements, particularly if the content doesn’t fit within a rectangular shape. Use the TouchUp Reading Order tool to add or remove content from a region, or to split a region to reorder the content.

- Select the TouchUp Reading Order tool.
- In the TouchUp Reading Order dialog box, select Show Page Content Order.
- In the document pane, select a highlighted region.

Do one of the following:

- To add content to the current selection, Shift-click the content you want to add. The pointer changes to include a plus sign (+).
- To remove content from the current selection, Ctrl-click/Command-click the content you want to remove. The pointer changes to include a minus sign (-).
- Click the button for the tag type that you want the highlighted region to be.

**Split a region into two regions**

- Select the TouchUp Reading Order tool.
- In the TouchUp Reading Order dialog box, select Show Page Content Order.
- In the document pane, drag to select a small portion of content near the boundary of the first region that you want to create.
- Click the Background button in the dialog box. The highlighted region splits into two regions, numbered from right to left.
- If you need to correct the reading order, click Show Order Panel, and drag the new highlighted region to the correct location in the Order tab. Drag to select the first content region you created, including the region you defined as Background, and then set the tag by clicking a button in the TouchUp Reading Order dialog box.
Apply a heading tag

To help readers navigate a document and find the information they need, make sure that headings are tagged with the appropriate level to indicate their hierarchy in the content.

- Select the TouchUp Reading Order tool, and then select the heading text in the PDF.
- In the TouchUp Reading Order dialog box, click the button corresponding to the appropriate heading tag (for example, Heading 1, Heading 2).

Remove page elements from the tag structure

When tagging a PDF, Acrobat can’t always distinguish between instructive figures and decorative page elements. Items that visually enhance page layout, such as decorative borders, lines, or background elements, can add clutter to the structure layout and should be removed. Therefore, Acrobat may incorrectly tag artifacts or page elements as figure tags. You can remove artifacts and irrelevant page elements from the tag structure by redefining them with the Background tag or by deleting their tags. If a tagged image in the document doesn’t contain useful or illustrative information for the user, you can remove the element from the tagging structure so that it isn’t read out loud or reflowed.

- Select the TouchUp Reading Order tool.
- In the TouchUp Reading Order dialog box, select Show Page Content Order and Show Tables And Figures.

Remove the page element by doing one of the following:

- In the document pane, select the page element, and then click Background in the dialog box.
- In the Order tab, select the page element, and then press Delete.

Apply a figure tag

You can select an element and define it as a figure by using the TouchUp Reading Order tool. Once you define it as a figure, you can add alternate text to describe the figure.

- Using the TouchUp Reading Order tool, select the figure.
- In the TouchUp Reading Order dialog box, click Figure.
- In the document pane, right-click the region and choose Edit Alternate Text (See “Figure 36. Add / Edit Alternate Text with TouchUp Reading Order” on page 46).
- Enter the desired alternate text in the Alternate Text dialog (See “Figure 37. TouchUp Reading Order Alternate Text Dialog” on page 46), and click OK.

Using TouchUp Reading Order to Check and Correct Figure Tags

You can use the TouchUp Reading Order tool to identify and correct tagging results for figures. Determine whether figures include or require alternate text in order to be read correctly with assistive technologies. Ideally, figure tags should identify image content that is meaningful to the document as a whole, such as graphs or illustrative photographs. If background elements that shouldn’t be read are tagged as figures, redefine them as background.
Select the TouchUp Reading Order tool, and then click Show Tables And Figures in the dialog box.

Do any of the following:

- If a figure isn't tagged as a figure, select the content region you want, and then click Figure or Figure/Caption in the dialog box.
- To remove text that was incorrectly combined with a figure, drag to select the text, and click the Text button in the dialog box.
- To include a caption that is grouped with the figure, select the figure and caption, and click the Figure/Caption button in the dialog box.

Adding Alternate Text with the TouchUp Reading Order Tool

If you want screen readers to describe graphical elements that illustrate important concepts in a document, you must provide the description using alternate text. Figures aren't recognized or read by a screen reader unless you add alternate text to the tag properties. If you apply alternate text to text elements, only the description, not the actual text, is read.

- Select the TouchUp Reading Order tool.
- Select Show Tables And Figures in the dialog box. Figures that are missing Alternate Text will have a flag indicating "Figure - No alternate text exists" (See “Figure 18 Add / Edit Alternate Text with TouchUp Reading Order” on page 28).
- Right-click the figure, and choose Edit Alternate Text from the pop-up menu. (See "Figure 36. Add / Edit Alternate Text with TouchUp Reading Order" on page 46).
- In the Edit Alternate Text dialog box, type a new (or edit an existing) description for the figure, and then click OK. (See “Figure 37. TouchUp Reading Order Alternate Text Dialog” on page 46)
Using the TouchUp Reading Order Tool Table Editor

Tables pose a special challenge for screen readers because they present textual or numerical data to be easily referenced visually. Content within table cells can be complex and might contain lists, paragraphs, form fields, or another table.

The TouchUp Reading Order Table Editor automatically analyzes the selected table into cells and applies the appropriate tags. The table must be tagged as a table before you can use TURO's Table Editor command on it.

For best results when tagging tables, use the application that you created the document with to add tags when you create the PDF. If a PDF isn’t tagged, you can add tags by using the Add Tags To Document command. Most tables are properly recognized using this command; however, the command may not recognize a table that lacks clear borders, headings, columns, and rows. Use the TouchUp Reading Order tool to determine if the table has been properly recognized and to correct recognition problems. To add specialized formatting to tables and table cells, use the Tags tab.

You can use the Table Editor to automatically analyze a table into its components and apply the appropriate tags, but you may still need to check and correct some of these tags manually. By viewing table tags, you can determine whether columns, rows, and cells have been correctly identified. Tables that lack well-defined borders and rules are often tagged incorrectly or contain adjacent page elements. You can correct poorly tagged tables by selecting and redefining them; you can split combined cells by creating a tag for each cell.

- Select the TouchUp Reading Order tool, and then click Show Tables And Figures.
- If the table isn’t clearly labeled in the document pane, drag to select the entire table, and then click Table in the dialog box.
• Click Show Table Cells to make sure that all cells in the table are defined as individual elements.

If cells don’t appear as separate elements, do one of the following:

• If one or more cells are merged, use the TouchUp Reading Order tool to select the area within a single cell, and then click Cell in the dialog box. Repeat for each merged cell.

• If cells aren’t highlighted, the table might not use standard table formatting. Re-create the table in the authoring application.

Add a Table Summary

With the cursor over the table, right click to add a Table Summary. The Edit Table Summary option is available in the menu that appears when you right-click a highlighted table. This allows the user to add or edit a text description about the table properties that is read by a screen reader or other assistive technology.

Place the Table in Editing Mode

There are two ways to place Tables in Table Editing Mode with the TouchUp Reading Order Tool:

• With the cursor over the table, right click to select Table Editor from the drop down list to place the table in Table Editing mode.

• You can also click the Show Order Panel in the TouchUp Reading Order dialog and select the table from the Order Panel. One technique is to highlight the snippets of text in the Order Panel that match the headings of the first row in the table. This often activates the Table Editor when it cannot otherwise be activated. You then select the Table Editor button on the TouchUp Reading Order dialog to place the table in Table Editing Mode (See “Figure 38. Using the Order Panel to Activate the Table Editor” on page 47).

Figure 38. Using the Order Panel to Activate the Table Editor

Once in Table Editing Mode, the borders of the table cells are highlighted. You can change the color of the border to suit your needs (See “Figure 39. Table Editing Mode” on page 48). You can select individual cells by clicking within the borders with the mouse. You can select multiple table cells by holding down Shift and clicking. This is an efficient method for selecting the first row of data cells in a table which need to be changed to header cells.
Once in Table Editing Mode, you can right click to display the Table Cell Properties dialog or the Table Editor Options dialog.

The Table Cell Properties dialog (See “Figure 40. Table Cell Properties” on page 49) allows you to:

- Specify the type of cell the selected cell should be, whether a Header cell or Data cell
- Set the cells attributes for row span and column span. Assign a unique header ID for Table Headers or associate Data cells with Header IDs that have been created for the table
The Table Editor Options dialog allows users to control how table cells and table headers are displayed by Acrobat when using the TouchUp Reading Order Table Editor (See "Figure 41. Table Editor Options" on page 49).

Note: To correct complex tagging problems for tables, you often must use the Tags Panel.
Remove or Replace Document Structure Tags

If the tags in a PDF file in Acrobat appear to be overly complicated you can try retagging an already tagged document. To do this, you must first remove all existing tags from the tree.

If adding tags to a PDF in Adobe Acrobat results in a tagging structure that is overly complicated or too problematic to fix, you can use the TouchUp Reading Order tool to remove or replace the current structure. If the document contains mostly text, you can select a page and then remove headings, tables, and other elements to create a cleaner, simpler tagging structure.

Acrobat can retag an already tagged document after you first remove all existing tags from the tree.

Replace the Existing Tag Structure on a Page

This procedure works best in pages that contain a single column of text. If the page contains multiple columns, each column must be selected and tagged individually.

- Select the TouchUp Reading Order tool.
- In the document pane, drag to select the entire page. The selection includes both text and nontext elements.
- Ctrl-drag/Command-drag around nontext page elements—such as figures and captions—to deselect them, until only text is selected on the page. Click Text in the TouchUp Reading Order dialog box.
- In the document pane, select a nontext page element, such as a figure and caption, and click the appropriate button in the dialog box to tag it. Repeat until all page content is tagged.

Remove All Tags from a PDF Document

To remove the tags from the entire PDF document, do the following:

- Open the Tags tab (View > Navigation Panels > Tags) and select the root (topmost) tag, Tags.
- In the Tags tab, choose Options > Delete tag.

**Note:** The Clear Page Structure command in the TouchUp Reading Order dialog box removes all tags from the currently visible pages and not from any pages that are not visible.

Complex Structures

While you can use the TouchUp Reading Order tool to create tags in untagged PDFs or to add new tags to an existing structure, this manual tagging doesn’t provide the same level of detail to the tagging structure as the Add Tags To Document command, such as paragraphs, bulleted and numbered lists, line breaks, and hyphens. Before you clear the existing structure, make sure that manual tagging is your only recourse.

To perform more advanced reading order and tagging tasks—such as fixing complex tables, removing obsolete tags after you delete pages, and adding alternative text to links—you may need to use the Content Panel and the Tags panel, which provide an alternate set of tools and features for manipulating PDF tags.
Content Panel

Use the Content Panel to correct reflow problems in a PDF that can’t be corrected by using the TouchUp Reading Order tool. Because you can damage a PDF by editing content objects, make sure that you’re familiar with PDF structure before you change anything. For comprehensive information about PDF structure, see the PDF Reference Sixth Edition: Adobe Portable Document Format Version 1.7, on the PDF reference page (English only) of the Adobe website.

The Content Panel provides a hierarchical view of the objects that make up a PDF, including the PDF object itself. Each document includes one or more pages, a set of annotations (such as comments and links), and the content objects for the page, consisting of containers, text, paths, and images. Objects are listed in the order in which they appear on the page, similar to tags in the logical structure tree. However, PDFs don’t require tags for you to view or change the object structure.

To display the Content Panel, choose View > Show/Hide > Navigation Panes > Content from the Acrobat X menu.

Click the plus sign (+) (Windows) or the triangle (Mac OS) next to the document name to view each page content entry. Cntrl + click expands the entire content tree.

---

Note: You may find it helpful to have Acrobat highlight items in the document view when the associated item in the Content Panel is selected. From the Content Panel Options Menu, select “Highlight Content” (See “Figure 42. Set Highlighting On for the Content Panel” on page 51).

---

Move a container or object by selecting it and doing one of the following:

- Drag it to the location you want.
- Choose Cut from the Options menu, select the tag above the location you want to paste the cut tag, and choose Paste from the Options menu.

---

Note: Container elements can’t be pasted directly to page elements. To move a container to another page, cut the container you want to move, select a container on the page you want to move the container to, and choose Paste from the Options menu. Then, drag the container out one level to the location that you want.
Content Tab Options

In the Content tab, use the Options menu or right-click an object to choose from the following options:

- **New Container.** Adds a new container object at the end of the selected page or container.
- **Edit Container Dictionary.** Specifies the dictionary for the container. Errors in this dialog box may damage the PDF. Available only for containers that include dictionaries.
- **Cut.** Cuts and copies the selected object (not the related page content)
- **Paste.** Pastes content directly below the selected object at the same hierarchical level.
- **Paste Child.** Pastes content into the selected object as a child content item.
- **Delete.** Removes the object (not the related page content) from the document.
- **Find Content From Selection.** Searches for the object in the Content tab that contains the object selected in the document pane.
- **Find.** Searches for unmarked (untagged) artifacts, content, comments, and links. Options allow you to search the page or document, and to add tags to found items.
- **Create Artifact.** Defines selected objects as artifacts. Artifacts are not read by a screen reader or by the Read Out Loud feature. Page numbers, headers, and footers are often best tagged as artifacts.
- **Remove Artifact.** Removes the artifact definition from the selected object.
- **Highlight Content.** When selected, highlights appear in the document pane around content that relates to a selected object in the Content tab.
- **Show Metadata.** Allows viewing and editing of image or object metadata.
- **Properties.** Opens the TouchUp Properties dialog box.

Order Panel

You can change the reading order of the highlighted regions by moving an item in the Order Panel or by dragging it on the page in the document pane (See "Figure 43. Acrobat X Pro Order Panel" on page 53). By reordering highlighted regions on the page, you can make a figure and caption read at the specific point that they are referenced in the text. By changing the order of a highlighted region, you effectively change the reading order of that item without changing the actual appearance of the PDF.

To display the Order Panel, do one of the following:

- **Select the TouchUp Reading Order tool.** In the TouchUp Reading Order dialog box, click Show Order Panel. Refer to the section on the TouchUp Read Order Tool for information on displaying the TouchUp Reading Order Tool "Use the TouchUp Read Order Tool (TURO)" on page 35.
- **Display the Order Panel.** From the Acrobat X Pro menu select View > Show/Hide > Navigation Panes > Order (Alt + V + S + N + O).
To change the order of content using the Order Panel:

In the Order panel, highlight an item in the list that corresponds to a numbered item in the document view. Push the item up or pull it down until it falls into the proper sequence.

![Acrobat X Pro Order Panel](image)

**Figure 43. Acrobat X Pro Order Panel**

**Tags Panel**

The Tags Panel allows you to view and edit tags in the logical structure tree, or tags tree, of a PDF file. In the Tags Panel, tags appear in a hierarchical order that indicates the reading sequence of the document. The first item in this structure is the Tags root. All other items are tags representing standard PDF structure elements and are children of the Tags root. Tags use coded element types that appear in angle brackets (< >). Each element, including structural elements such as sections and articles, appears in the logical structure order by type, followed by a title and the element's content or a description of the content. Structural elements are typically listed as container—or parent—tags and include several smaller elements—or child tags—within them.

Though you can correct many tagging issues by using the TouchUp Reading Order tool, you must use the Tags Panel to address detailed tagging of tables and substructure items—such as paragraphs, lists, and sections that require multiple languages. Add tags manually to a document using the Tags tab only as a last resort. First consider using the Add Tags To Document feature.

---

**Note:** Important! Operations performed in the Tags tab cannot be undone with the Undo command. Save a backup copy of a document before you begin work on it in the Tags tab.

- To display the Tags Panel Choose View > Show/Hide > Navigation Panes > Tags (Alt + V + S + N + G).
- You can expand or collapse the tag for an individual element or section you want by clicking on it.
- You can expand or collapse the entire tree or a node on the tree that has childred with Ctrl-click the plus sign (Windows) or Option-click the triangle (Mac OS) next to the Tags root (or nood) to show all tags in the logical structure tree.
Note: You may find it helpful to have Acrobat highlight items in the document view when the associated item in the Tags Panel is selected. From the Tags Panel Options menu, select “Highlight Content” (See “Figure 44. Set Content Highlighting On for the Tags Panel” on page 54).

Edit tags with the Tags Panel

You can edit a tag title, change a tag location, or change the tag type for an element. All page content must be tagged, marked as an artifact, or removed from the logical structure tree.

To reveal the TouchUp Properties (See “Figure 45. Revealing TouchUp Properties for Tags” on page 55) for any tag select the desired tag in the Tags panel and do one of the following:

- Right click and select Properties from the context menu
- Select Properties from the Tags Panel Option Menu
Edit a tag title

- In the Tags tab, expand the section of the logical structure that you want to edit.
- To edit the title, select the tag, choose Properties from the Options menu, enter text in the Title box, and click Close.

Move a tag

In the Tags tab, expand the Tags root to view all tags. Select the Tag icon of the element that you want to move.

Then do one of the following:

- Drag the tag to the location you want. As you drag, a line appears at viable locations for placing the tag.
- Choose Cut from the Options menu, and select the tag that appears above the location you want to paste the cut tag. From the Options menu, choose Paste to move the tag to the same level as the selected tag, or choose Paste Child to move the tag within the selected tag.

Change the element type

In the Tags tab, expand the section of the logical structure that you want to change.

- Select an element and choose Properties from the Options menu.
- Choose a new element type from the Type menu, and then click Close.
Tags tab options

In the Tags tab, use the Options menu or right-click a tag in the logical structure tree to choose from the following options:

- **New Tag.** Creates a new tag in the logical structure tree after the currently selected item. Specify type and title of the new tag.

- **Cut.** Removes the selected tag from its current location and puts it on the clipboard.

- **Paste.** Places the tag that's on the clipboard into the location specified, replacing the selected tag.

- **Paste Child.** Places the tag that's on the clipboard into the location specified, as a child of the selected tag.

- **Delete Tag.** Removes the selected tag.

- **Find Tag From Selection.** Searches for the tag in the Tags tab that contains the text or object selected in the document pane.

- **Create Tag From Selection.** Creates a new tag in the logical structure tree after the item selected in the document pane. Specify type and title of the new tag.

- **Find.** Searches for artifacts, OCR suspects, and unmarked (untagged) content, comments, links, and annotations. Options allow you to search the page or document and add tags to found items.

- **Change Tag To Artifact.** Changes selected tags to artifacts and removes the tagged content from the structure tree.

- **Copy Contents To Clipboard.** Copies all content contained within the selected tags.

- **Edit Class Map.** Allows you to add, change, and delete the class map, or style dictionary, for the document. Class maps store attributes that are associated with each element.

- **Edit Role Map.** Allows you to add, change, and delete role maps for the document. Role maps allow each document to contain a uniquely defined tag set. By mapping these custom tags to predefined tags in Acrobat, custom tags are easier to identify and edit.

- **Tag Annotations.** When selected, all new comments and form fields are added to the tag tree after the selected tag element; existing comments and form fields aren't added to the tag tree. Highlight and Underline comments are automatically associated and tagged with the text that they annotate and don't require this option.

- **Document Is Tagged PDF.** Flags the PDF as a tagged document. Deselect to remove the flag.

- **Highlight Content.** When selected, causes highlights to appear around content in the document pane when you select the related tag in the Tags tab.

- **Show Metadata.** Opens a read-only dialog box that contains reference information about the selected tag.

- **Properties.** Opens the TouchUp Properties dialog box.
Add alternate text and supplementary information to tags

Some tagged PDFs might not contain all the information necessary to make the document contents fully accessible. For example, if you want to make a document available to a screen reader, the PDF should contain alternate text for figures, language properties for portions of the text that use a different language than the default language for the document, and expansion text for abbreviations. Designating the appropriate language for different text elements ensures that the correct characters are used when you repurpose the document and that it is spell-checked with the correct dictionary.

You can add alternate text and multiple languages to a tag from the Tags tab. (If only one language is required, choose the language with File > Properties instead.) You can also add alternate text by using the TouchUp Reading Order tool.

Note: Keep alternate text descriptions as concise as possible.

Add alternate text to links

Screen readers can read the URLs of web links out loud, but adding meaningful alternate text to links can help users immensely. For example, by adding alternate text you can have a screen reader tell a user to "go to the Acrobat accessibility page at adobe.com" rather than "go to http://www.adobe.com/accessibility/products/acrobat/.

You add alternate text to the <Link> tag of a link.

Note: You must add alternate text only to tags that don’t have child tags. Adding alternate text to a parent tag prevents a screen reader from reading any of that tag’s child tags.

- In the tag tree, select the <Link> tag for the link and choose Options > Properties.
- In the TouchUp Properties dialog box, select the Tag tab.
- Type the alternate text for the link, and click Close.

Add alternate text to a figure

- Choose View > Navigation Panels > Tags.
- Expand the logical structure tree to find and select the <Figure> tag element for the image.
- Choose Highlight Content from the Options menu in the Tags tab to see a highlighted area in the document that corresponds to the tag.
- Choose Properties from the Options menu in the Tags tab.
- In the TouchUp Properties dialog box, click the Tag tab.
- For Alternate Text, type text that describes the figure.

Add alternate text for an abbreviated term

In the Tags panel, locate the abbreviated term by doing one of the following:
• Expand the tag tree as needed to see the elements that contain the abbreviation.

• Use the TouchUp Text tool or the Select tool to select the abbreviation in the document, and then choose Find Tag From Selection from the Options menu to locate the text in the tag tree.

• Select the tag for that element, and choose Properties from the Options menu.

---

Note: If the abbreviation includes additional text, cut the additional text and place it in a new <Span> child tag within the same <Span> parent tag.

---

Once you have selected the abbreviated term, add the unabbreviated (expanded) version of the term.

• In the TouchUp Properties dialog box, select the Tag tab.

• For Alternate Text, type the unabbreviated version of the term.

• Click Close.

Create a new child tag

• In the Tags tab, select the parent node (the icon located at the same level at which you want to create a child tag) in the Tags tree for which you want to create a child tag.

• Choose New Tag from the Options menu.

• Select the appropriate tag type from the Type pop-up menu, or type a custom tag type, name the tag (optional), and then click OK.

Add tags to comments

When you tag a PDF that includes comments, the comments are tagged as well. However, if you add comments to a PDF that’s already tagged, your comments are untagged unless you enable comment tagging first.

---

Note: To Enable comment tagging in a PDF, in the Tags tab, choose Tag Annotations from the Options menu. Comments or markups that you add to the PDF are tagged automatically.

---

If a document contains untagged comments, you can locate them in the logical structure tree and tag them by using the Find command in the Tags tab.

• In the Tags tab, choose Find from the Options menu.

• In the Find Element dialog box, choose Unmarked Comments from the Find pop-up menu, and click Find.

• When the comment type appears in the Type field (for example, Text), click Tag Element, choose Annotation from the Type pop-up menu in the New Tag dialog box, and then click OK.

• In the Find Element dialog box, click Find Next to locate and tag all comments, and then click Close.
Correct Table Tags with the Tags Tab

Use the TouchUp Reading Order tool to make sure that tables are tagged correctly. If you need to structure figures and text within the cells of your table, you may prefer to re-create the table in the authoring application before you convert it as an accessible PDF. Adding tags on a cell level in Acrobat is a labor-intensive procedure.

Before you make any changes to table elements, use the TouchUp Reading Order tool to determine that the table is tagged correctly.

Check table elements

- In the Tags tab, expand the tags root to view a table tag.
- Select the table tag `<Table>` and verify that it contains one of the following elements:
  - Table Rows `<TR>`, each of which contains Table Header `<TH>` or Table Data `<TD>` cells
  - `<THead>`, `<Tbody>`, or `<TFoot>` section, each of which contains Table Rows (The Table Rows contain `<TH>` cells, `<TD>` cells, or both).

Do one or more of the following:

- If the tag for the table doesn’t contain these elements, but rows, columns, and cells appear in the table in the document pane, use the TouchUp Reading Order tool to select and define the table or individual cells.
- If the table contains rows that span two or more columns, set ColSpan and RowSpan attributes for these rows in the tag structure.
- Re-create the table in the authoring application, and then convert it to a tagged PDF.

Set ColSpan and RowSpan attributes

- In the Tags tab, select a `<TD>` or `<TH>` element.
- Choose Properties from the Options menu.
- In the TouchUp Properties dialog box, click the Tag tab, and then click Edit Attribute Objects.
- Select Attribute Objects, and then click New Item to create a new Attribute Object Dictionary.
- Expand the new dictionary, select the Layout attribute, and then click Change Item.
- Change the Layout value to Table.
- Select the Attribute Object Dictionary, and click New Item.
- In the Add Key And Value dialog box, type ColSpan or RowSpan in the Key box, enter the number of columns or rows spanned in the Value box, choose Integer from the Value Type pop-up menu, and click OK.
Step 7: Use the Accessibility Checker to Evaluate the PDF File

Once you have performed the previous steps. Check the PDF file using the Adobe Acrobat X Pro accessibility checker. See the document Adobe® Acrobat® X Pro Accessibility Guide: Using the Accessibility Checker for complete instructions.

Note: The accessibility checker tools (Quick Check and Full Check) can help to identify areas of documents that may be in conflict with Adobe's interpretations of the accessibility guidelines referenced in the application and its documentation. However, these tools don't check documents against all accessibility criteria, including those in such referenced guidelines, and Adobe does not warrant that documents comply with any specific guidelines or regulations.

Use Full Check to perform a thorough check for many characteristics of accessible PDFs, such as the use of fonts that can be mapped reliably to Unicode text.

Full Check checks a PDF for many of the characteristics of accessible PDFs.

You can choose which kinds of accessibility problems to look for and how you want to view the results. To run the full Accessibility Check, do the following:

- In Adobe Acrobat Pro X, you must first reveal the Accessibility Tool pane. If it is not already displayed, select View > Tools > Accessibility from the Adobe Acrobat X Pro menu. The keyboard accelerator is Alt+V+T+A (See “Figure 46. Acrobat X Pro Accessibility Full Check Panel” on page 61).

- With the Accessibility Tool Pane revealed, you can select the Full Check panel.

- Selecting the Full Check panel brings up the Accessibility Full Check dialog.

- You can save the results as an HTML file or as comments that are located where the accessibility problems are detected.

- Select a page range if you prefer to do a full check on individual sections of a document.

- Select an accessibility standard (Adobe PDF, Section 508 (U.S.), or W3C) from the Name menu, and then select the accessibility options to check for.

- Click Start Checking.
The results are displayed in the left panel, which also has helpful links and hints for repairing issues (See “Figure 48. Acrobat X Pro Accessibility Report” on page 62). If you created a report in step 2, the results are available in the selected folder. Clicking on the links highlights the problem areas in the document. The Accessibility Checker panel also provides hints for repair which you should follow.
Because the Full Check feature is unable to distinguish between essential and nonessential content types, some issues it reports don’t affect readability. It’s a good idea to review all issues to determine which ones require correction.

### Accessibility Full Check Options

- **Create Accessibility Report**. Creates an HTML report of accessibility issues, which is opened in the navigation pane and saved in the location indicated by the Folder field.

- **Include Repair Hints In Accessibility Report**. Adds suggestions for fixing accessibility problems to the HTML report or comments.

- **Create Comments In Document**. Adds comments to the document that indicate accessibility problems. Delete all accessibility comments from the PDF after you repair the accessibility issues.

- **Page Range**. The range of pages to check.

- **Name**. The set of accessibility criteria to check. For the Section 508 and W3C guidelines, the options area includes a Browse button that links to the website for the respective guidelines. Select Adobe PDF to choose from options for the Adobe PDF accessibility standard.

- **Alternative Descriptions Are Provided**. Checks for tagged figures that are missing alternate text.

- **Text Language Is Specified**. Checks for paragraphs that don’t have a language specified for them. Setting the language for an entire document in the Document Properties dialog box corrects all errors related to this option.

- **Reliable Character Encoding Is Provided**. Checks for fonts that are inaccessible to screen readers and other assistive software. Fonts must contain enough information for Acrobat to correctly extract all the characters to text. If one or more fonts don’t allow for the correct extraction of all the characters, the PDF is inaccessible.

- **All Content Is Contained In The Document Structure**. Checks for page elements that may have been overlooked during tagging. Adding these elements to the tag tree (if necessary) ensures that a screen reader can present the content to a user.
- **All Form Fields Have Descriptions**. Checks for form fields that are missing descriptions.

- **Tab Order Is Consistent With The Structure Order**. Checks whether tags properly reflect the document’s structure.

- **List And Table Structure Is Correct**. Checks whether tags that have been generated for lists and tables meet the requirements of tagged PDF.

**Continue Checking Until All Issues are Addressed**

Repeat the process of running the Accessibility Checker and using familiar repair techniques or following the Hints for Repair until the Accessibility Checker indicates “The checker found no problems in this document” for the tests you have selected (See “Figure 49. A Successful Accessibility Check” on page 63).

**Note:** While the Accessibility Checker helps you evaluate the accessibility of your documents and helps identify areas that may be in conflict with Adobe’s interpretations of the referenced guidelines, the Accessibility Checker does not check all accessibility guidelines and criteria, including those in such referenced guidelines, and Adobe does not warrant that your documents will comply with any specific guidelines or regulations. Please consult with your legal counsel for guidance on compliance with the referenced guidelines or any other accessibility guidelines.

**Figure 49.** A Successful Accessibility Check

**Additional Validation Techniques**

Of course, the best way to test the accessibility of a document is to attempt to use the document with the tools that your readers will use. However, even if you don’t have a screen reader or braille printer, you can still use any of several methods provided by Acrobat for checking the accessibility of a PDF file.

- Use Reflow view to quickly check reading order.

- Use Read Out Loud to experience the document as it will be experienced by readers who use this text-to-speech conversion tool.

- Save the document as accessible text and then read the saved text file in a word-processing application to experience the document as it will be experienced by readers who use a braille printer.
Acrobat X Pro Accessible Forms and Interactive Documents

Create interactive forms that can be used by anyone, ensuring privacy and independence for all

Determining if a PDF file can be used as an interactive form is a matter of visually examining the file and looking for the presence of form fields, or areas in the document where users are asked to provide some kind of information such as name, address, telephone number, or email address. Respondents might be asked to indicate a preference or status by checking a box. If you want users to be able to complete the form online, rather than resort to printing a paper copy in order to complete the form, then the form should be an accessible interactive form.

With Adobe Acrobat X Pro, you can make interactive form fields accessible to vision impaired users and users with mobility challenges by adding properly encoded fillable fields to the PDF file. You can also structure the form in such a way that users can use the tab key to move between fields in a meaningful and logical sequence. In addition, entries in the Tooltips field property can provide users of assistive technology, such as screen readers, with additional information about the field or to provide instructions. These tooltips are read by screen readers for the blind and visually impaired.

For example, using the Tooltips property value, you could add text to a check box on an RSVP that users would use to indicate their intention to attend an awards dinner. You can encode the checkbox so the screen reader user would hear "I plan to attend the awards dinner." Without adding such alternate text to the check box's tool tip property, a screen reader simply provides the name of the form field (Check Box 1), its type (Check Box), and its state (Unchecked). Screen reader users would hear "Check Box Checked" or "Check Box Unchecked" depending upon whether or not the box had been checked. It would not be clear to users listening to the form with a screen reader that the checkbox indicates their intention to attend the event. This is true even if there is a visible label next to the checkbox which reads, "Check this box if you plan to attend the awards dinner." You need to add the tooltip text to the checkbox or radio button properties.

Acrobat X Pro can detect and create the form fields automatically or you can manually create the necessary fields using Acrobat X Pro's form editing tools. If you choose to have Acrobat automatically detect form fields, it will attempt to locate any labels that are adjacent to the form field or check box and use any labels it does find as the source for alternate text (called a tooltip in Acrobat).

Note: This discussion limits itself to the accessibility issues involved with creating form fields with the Acrobat X Pro form tools. For a more detailed discussion of PDF forms including forms created with the Adobe LiveCycle Designer or the Adobe Digital Enterprise Platform Designer, refer to the Acrobat X Pro online help.

PDF Form Fields
A PDF form created with Adobe Acrobat X Pro’s forms editing tools can contain the following types of fields:

- **Text field.** Lets the user type in text, such as name, address, or phone number.

- **Check box.** Presents yes-or-no choices for individual items. If the form contains multiple check boxes, the user can typically select as many or few of these as needed.
• **Radio button.** Presents a group of choices from which the user can select only one item from the group. All radio buttons with the same name work together as a group.

• **List box.** Displays a list of options the user can select. You can set a form field property that enables the user to Shift-click or Control-click to select multiple items on the list.

• **Combo box.** Lets the user either choose an item from a pop-up menu or type in a value.

• **Button.** Initiates a change on the user’s computer, such as opening a file, playing a sound, or submitting data to a web server. These buttons can be customized with images, text, and visual changes triggered by mouse actions. Action buttons have a different purpose than radio buttons, which represent data choices made by the user.

• **Digital signature field.** Lets the user electronically sign a PDF document with a digital signature.

• **Barcode.** Encodes the input form selected fields and displays it as a visual pattern that can be interpreted by decoding software or hardware (available separately).

**Use Acrobat to Detect and Create Interactive Form Fields**

You can convert an existing electronic document (for example a Word, Excel, or PDF document) or scan a paper copy into Acrobat, and Acrobat will add interactive fields to the form.

When you convert a document to an interactive form, Acrobat X Pro can detect the form fields in the document. In many instances, Acrobat will use the form field labels to name the field and provide a Tooltip. While the results are often acceptable, this is not a foolproof process. You will need to examine the document carefully to verify that Acrobat accurately detected the fields and labelled them properly.

** Acrobat Form Wizard**

You can use the Form Wizard in Adobe Acrobat X Pro to create interactive forms from an existing electronic document (for example a Word, PDF, or Excel document) or from a paper form that was placed in a scanner with the resulting image opened in Acrobat.

• **Open a PDF document using Adobe Acrobat X Pro.** A quick examination of the document should indicate whether it is a form.

• **Display the Create Command in the Forms Task Panel.** The Forms Task Panel is under the Tools Pane. From the Acrobat X Pro menu, you can select View > Tools > Forms to expose the Forms Task Panel under the Tools Pane (See "Figure 50. Create Form Command in the Forms Task Panel" on page 67). The keyboard accelerator for displaying the Forms Task Panel is Alt + V + T + F.
Select the Create command (Keyboard Shortcut is Shift + Ctrl + 7). This displays the Create or Edit Form Dialog (See "Figure 51. Acrobat X Pro Create or Edit Form Dialog" on page 67).

- **Use an existing file.** This converts an existing electronic document (for example Word or PDF) to an interactive PDF form. To use the document that is currently on display, select "Next" and "Use the current document." Select "Next" again. Acrobat automatically searches for and creates any form fields it detects, and places the document in Form Editing Mode. Acrobat informs you that it has entered Form Editing Mode. When you select "OK", the document is displayed in Form Editing Mode (See "Figure 52. Adobe Acrobat X Forms Editing Mode" on page 68).

- **Scan a paper form.** To scan a paper form and convert it to a PDF form. The form will be scanned, converted to PDF and Acrobat will search for and create any form fields it detects. The form is placed in Form Editing Mode (See "Figure 52. Adobe Acrobat X Forms Editing Mode" on page 68).
Create a web form or survey from scratch or template. This creates an Online Form using Adobe Forms Central. Using Adobe Forms Central is not a topic that is addressed in this Best Practices Guide.

Note: Using the Adobe LiveCycle Designer, included in Adobe Acrobat X Pro for Windows, to create accessible PDF forms is not a topic that is addressed in this Best Practices Guide.

Assuming you selected either the Use and Existing File or Scan a paper form options, Acrobat X Pro completes an analysis of the document, adds any form fields it may detect and places the PDF form in Forms Editing Mode. Your document will look similar to what is shown in "Figure 52. Adobe Acrobat X Forms Editing Mode" on page 68. While in Forms Editing Mode, you can add to, edit or delete the automatically created form fields (See "Forms Editing Mode" on page 69).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It may have also created fields of the wrong type. You should verify the fields and field names on the form. You can select Add New Field on the Forms Editing toolbar to add more fields or right click on the form to add, edit, or delete fields.

**Enter Forms Editing Mode Directly**

If you don't want to use the Form Wizard, you can open the file, and place the document in Form Editing Mode directly.

- **From the Acrobat Menu.** Select View > Tools > Forms and select the Edit command under the Forms Tool Pane (Keyboard shortcut is Shift + Ctrl 7). This displays the Add or Edit Form Fields dialog (See “Figure 53. Acrobat X Pro Add or Edit Form Fields Dialog” on page 69).

  Answering "Yes" to the Add or Edit Form Fields dialog question "Do you want Acrobat to detect form fields for you?" results in the automatic detection of form fields prior to placing the document in Form Editing Mode. This is the same as if you had proceeded using the Form Wizard on the current PDF.
Acrobat completes its analysis of the document, adds any form fields it may detect and places the PDF form in Forms Editing Mode where you can edit the automatically created fields or add additional form fields (See “Forms Editing Mode” on page 69).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It may have also created fields of the wrong type. Please verify the fields and field names on your form. You can select Add New Field on the Forms Editing toolbar to add more fields or right click on the form to edit or delete fields.

Answering “No” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect form fields for you?” also places the document in Form Editing mode, but does not create form fields automatically. You will have to add the form fields manually. Proceed to the next section, “Create Form Fields Manually” on page 5 for further information.

Create Form Fields Manually

To add form fields manually do the following:

- **From the Acrobat Menu.** Select View > Tools > Forms and select the Edit command under the Forms Tool Pane (Keyboard shortcut is Shift + Ctrl 7). This displays the Add or Edit Form Fields dialog (See "Figure 51. Acrobat X Pro Create or Edit Form Dialog" on page 67).

- Select the Edit Command > (Keyboard shortcut is Shift + Ctrl 7) and answer "No" to the question "Do you want Acrobat to detect Form Fields for you?" (See "Figure 51. Acrobat X Pro Create or Edit Form Dialog" on page 67). This places the document in Forms Editing Mode without automatically creating any fields.

- You can now add new form fields to the PDF form by selecting one of the options from the Add New Field Command. This is a drop down menu that presents the 8 Acrobat field types. Proceed to the next section “Forms Editing Mode” on page 69 for further instruction.

Forms Editing Mode

With the PDF form in Forms Editing Mode, you can add new fields and buttons to the form and edit or delete any existing field or button. The Acrobat X User Interface changes when in Forms Editing Mode (See “Figure 52. Adobe Acrobat X Forms Editing Mode” on page 68).

- A Forms Editing Toolbar provides access to the Select Object tool, the Add New Field button, and the Form Preview button. You can configure the Add New Field button to display the Forms tools on the toolbar instead of the Add New Field button if you prefer.
• On the right hand side of the Forms Editing Toolbar, beneath the Tasks pane, the Add New Field Command, Distribute Command, Track Command, Close Form Command, and Other Tasks Command are displayed under the Tasks panel.

• A fields panel appears below the Tasks panel showing any interactive fields that are currently part of the form.

Creating a New Form Field

In Acrobat X Pro, you create a form field by choosing one of the form tools. For each field type, you can set a variety of options through the form field Properties dialog box.

You can access the forms tools one of three ways.

• You can select "Add New Field" under the task panel (See "Figure 54. Adobe Acrobat X Add New Field Command" on page 70).

![Figure 54. Adobe Acrobat X Add New Field Command](image)

• You can select one of the Forms Tools icon from the Forms Tool Bar that appears below the Acrobat X Pro menu bar (See "Figure 55. Adobe Acrobat X Forms Tools Icons" on page 71).
You can right click over the form to present options that allow you to add, edit, or delete fields (See “Figure 56. Adobe Acrobat X Right Click Forms Dialog” on page 71).

Adobe Acrobat X Forms Editing Mode

Once you have selected a form tool, the cursor becomes a cross hair and a light blue region defines the outline of the form object you have selected for placement.

- On the page, click where you want to add the field to create a field with the default size. To create a field using a custom size, drag a rectangle to define the size of the field.
- In the Field Name box, type the name of the field, if you want to change it from the default name that Acrobat provides. Acrobat provides a default name based upon the field type and the number of fields drawn on the page. You should choose a name that is relevant and descriptive to make organizing and collecting the data easier (See “Figure 57. Field Name Box” on page 72).
• At this point you can also specify if you want the field to be a required field. To display the Properties dialog box and modify any other field properties, click Show All Properties (See “Figure 57. Field Name Box” on page 72).

Note: If you have checked the "Keep Tool Selected" option in the forms toolbar, the Field Name box doesn't appear after adding a field. Each time you click the page, a new field is added to the form. To exit this mode, press the Esc key or click the Select Object Tool button. To modify the properties of the field, double-click the field.

To test your form, click the Preview button at the top of the document window. Previewing a form allows you to view the form the same way the form recipients will see it and gives you a chance to verify the appearance and behavior of the form. If you are previewing a form, you can click the Edit Layout button to return to Forms Editing mode.

Form Field Properties

How a form field behaves is determined by settings in the Properties dialog box for that individual field. You can set properties that apply formatting, determine how the form field information relates to other form fields, impose limitations on what the user can enter in the form field, trigger custom scripts, and so forth.

You can set a variety of properties for an Acrobat form field, depending on the form field type. The properties for each type of form field are selected on a series of tabs. When you change a property, it is applied as soon as you select another property or press Enter.

All the form field types have a General tab, Appearance tab, and an Actions tab. Other tabs appear only in specific types of form fields. The Options tab appears for most form field types but the options available are unique to each type of form field.

If you are changing the properties of multiple fields, you can leave the Properties dialog box open. Click on each field to change its properties.

Tooltips for Form Fields

For accessibility, the Tooltip option on the General tab is important for entering text that will be announced by screen readers.
You can make form fields accessible to people with disabilities by adding tags to the PDF and by properly structuring it. In addition, you can use the tool tip form field property to provide the user with information about the field or to provide instructions. For example, using the tool tip property value, the screen reader could say "Your first name." Without the tool tip property, a screen reader announces the type and name of the form field (See “Figure 58. Adding a Tooltip to a Form Field” on page 73).

- If necessary, choose Forms > Add or Edit Fields, and make sure that the Select Object tool is selected.
- Double-click a selected form field to open the Properties window.
- In the General tab, type a description into the tool tip box.

The Tooltips also display text that users may find helpful in filling in the form field. Tooltips appear when the pointer hovers briefly over the form field.

![Figure 58. Adding a Tooltip to a Form Field](image)

Tooltips for Radio Buttons

To create a set of mutually exclusive Radio Buttons, where only one field can be selected at a time, give each field the same name and the same Tooltip, but different Button values. The Button value is a field in the options tab of the Radio Button Properties dialog.

To make a radio button accessible, in addition to entering unique text in the Button Value field for each choice, you would enter identical text in the Tooltip field of the General properties tab for each radio button in the group (See “Figure 59. Identical Button Name and Tool Tip Value for a Radio Button Group” on page 74).

For example, you may need to create a radio button group that asks the question, “Do You Need a Hotel Room Reservation?”

- You would create two radio buttons. For each button, you might choose to give the button the identical name, “Hotel Reservation.” For each button, you would enter identical text in the Tool tip field, such as “Do You Need a Hotel Room Reservation?” (See “Figure 59. Identical Button Name and Tool Tip Value for a Radio Button Group” on page 74).
Figure 59. Identical Button Name and Tool Tip Value for a Radio Button Group

- For the button next to the label indicating Yes, you would enter “Yes” in the Button Value field under the options tab (See “Figure 60. Setting One Radio Button in a Group to Indicate “Yes”” on page 75). For the other, the one next to the No label, you would enter “No” in the Button Value field (See “Figure 61. Setting One Radio Button in a Group to Indicate “No”” on page 75).
Editing or Modifying an Existing Form Field

You can access Acrobat form field properties only when you are in editing mode (by choosing Forms > Add Or Edit Fields). You can change the properties for multiple form fields at a time.

Open the Properties dialog box using one of the following methods:

- To edit a single form field, double-click it or right-click/Control-click it and choose Properties.
- To edit multiple form fields, select the fields that you want to edit, right-click/Control-click one of the selected fields, and choose Properties.

Change the properties on each of the available tabs, as needed. The property is changed as soon as you select another property or press Enter.

- Click Close to close the Properties dialog box.

If you select form fields that have different property values, some options in the Properties dialog box are not available. Otherwise, changes to the available options are applied to all selected form fields.
To avoid accidental changes to the form field, select Locked in the lower left corner of the Properties dialog box before you close it. To unlock, click the check box again.

Deleting a Form Field

With the document in Forms Editing mode, click on the field you would like to delete and do any of the following.

- Right mouse click and select delete
- Press the delete key.
- From the menu, select Edit > Delete (ALT + ED)

Note: You can select multiple fields by holding the Control key as you click on each one.

Buttons

Buttons are most commonly associated with forms, but you can add them to any document. Buttons can open a file, play a sound or movie clip, submit data to a web server, and much more. When deciding on how to initiate an action, remember that buttons offer the following capabilities that links and bookmarks do not:

- A button can activate a single action or a series of actions.
- A button can change appearance in response to mouse actions.
- A button can be easily copied across many pages.
- Mouse actions can activate different button actions. For example, Mouse Down (a click), Mouse Up (releasing after a click), Mouse Enter (moving the pointer over the button), and Mouse Exit (moving the pointer away from the button) can all start a different action for the same button.

Buttons are an easy, intuitive way to let users initiate an action in PDF documents. Buttons are added the same way as form fields while in Forms Editing mode. They also should be given a name and a Tooltip and their behavior is determined by the actions the user assigns the button on the actions tab of the Button Properties dialog. They also appear in the Tab order tree. See the Adobe Acrobat Help for a complete discussion of PDF fields and buttons.

Set the Tab Order

If a PDF document doesn't have a specified tab order, the default tabbing order is based on the document structure unless the user has deselected the Tab Order option in the Accessibility preferences.

You can change the tabbing order after you create the fields.

- If you are in Forms Editing mode, you can order the tabs by document structure (default), row, or column.
- You can also choose the order manually by dragging and dropping fields in the Fields panel.
- If you are not in Forms Editing mode, you can change the page properties to order the tabs by row or column. However, you can’t customize the tab order manually.
To change the tab order, first select “Order Tabs Manually” from the Tab Order button on the Fields panel. Then you can drag and drop fields where you want them within the Fields panel to modify the tab order (See “Figure 62. Rearranging Tab Order with the Fields Panel” on page 77). To assist in determining tab order, you can select “Show Tab Numbers” from the Tab Order button of the Fields panel (See “Figure 62. Rearranging Tab Order with the Fields Panel” on page 77).

In the example shown in Figure 62 on page 77, Text Field 1 “District” is in the second position though it should be first. Text Field 2, “Date Due” is in the first position, though it should be second. Selecting the entry for Text2 in the Forms panel highlights the corresponding field in the document view. To move it to the second position, drag it down and drop it below the entry for Text1 (or you could pushed Text1 up above Text2). Refer to “Figure 62. Rearranging Tab Order with the Fields Panel” on page 77 to see the relationship between items in the Fields Panel and the Document pane. Note also the Order Tabs Manually and the Show Tab Numbers options are highlighted.

Figure 62. Rearranging Tab Order with the Fields Panel

Add Other Accessibility Features

This stage includes setting the document language, making sure that security settings do not interfere with screen readers, creating accessible links, adding tags to the document and adding bookmarks. There may be other tasks to complete on your file before it can be considered accessible. For a discussion on how to proceed from this point, refer to the document Adobe Acrobat X Pro Accessibility Guide: PDF Accessibility Repair Workflow.
Creating Accessible PDF Files from Microsoft® Word

Use Acrobat X Pro and popular word processing software to create PDF files that are accessible to persons with disabilities.

In Microsoft Windows®, Acrobat installs both an Acrobat PDFMaker toolbar and an Adobe PDF menu in many popular Microsoft authoring applications. PDFMaker provides conversion settings that let you create tagged accessible PDFs in Microsoft Word, Excel®, and PowerPoint®.

You can use either the toolbar buttons or the Adobe PDF menu to create PDFs, but the menu also provides access to conversion settings. Although many of the conversion options are common to all the Microsoft Office applications, a few are application-specific.

---

Note: For Microsoft Office 2007 and 2010 applications such as Word, Excel, PowerPoint, and Access, the options for creating PDFs are available from the Acrobat Ribbon.

---

In general, the following rules apply.

- Design your source document with accessibility in mind
- Do NOT use character formatting for headings, use the program's styles.
- Do add alternative text to graphics in the source file
- Do use a table editor if available to create tables
- Do NOT use a table editor to design layouts
- Do generate the PDF file in a way that generates tags
- Do set your PDF output preferences option to tagged PDF
- Do check the results in Adobe Acrobat X Pro using Advanced > Accessibility > Full Check (shortcut: Alt + A + A + F)
- Do follow the suggestions for repair and repeat checking until no errors are detected
Create an Accessible Microsoft Word Document

You should author the original source document with accessibility in mind. This means you should add structure to the document by using styles rather than character formats for such items as headings and lists. You should also add alternate text descriptions to graphics that appear in the Word file using the format picture dialog. You should use Word’s column command and not tables to create multi-column documents.

Use Styles

Design your documents with styles. Styles add the structure necessary to make your documents usable to people with disabilities.

Text

The default text style for Microsoft Word is Normal.

- Text should be at least 12 point type.
- Avoid using Microsoft Word text boxes.
- Avoid using Enter to create space between paragraphs. Use the space before and space after properties of paragraphs in your styles.

Headings

Use Styles to create heading formats. Title, Heading 1, Heading 2, Heading 3, etc. Make styles progress in a logical manner, a Heading 2 should come after a Heading 1.

Word 2003 Headings

To create headings in Microsoft Word 2003 do the following:

- From the menu, select Format > Styles and Formatting to reveal the styles and formatting task pane (See “Figure 63. Microsoft Word 2003 Styles and Formatting panel, selected from the Format” on page 79).
- Apply the appropriate heading from the Styles and Formatting panel to your document text.

Figure 63. Microsoft Word 2003 Styles and Formatting panel, selected from the Format

- You can also click on the Columns Toolbar.
Word 2007 Headings

- Select the Home Ribbon in Word 2007 and select the proper heading from the styles group (See “Figure 64. Microsoft Word 2007 Styles and Formatting” on page 80).

![Figure 64. Microsoft Word 2007 Styles and Formatting](image)

Word 2010 Headings

- Select the Home Ribbon in Word 2010 and select the proper heading from the styles group (See “Figure 65. Microsoft Word 2010 Styles and Formatting” on page 80).

![Figure 65. Microsoft Word 2010 Styles and Formatting](image)

Columns

To create columns, do not use the tab key or the spacebar to create space between columns of text. Also avoid using text boxes or placing text in a table. The proper method is to use Word’s Column layout feature.

Word 2003 Columns

- From the menu, select Format > Columns to reveal the columns dialog (See “Figure 66. Microsoft Word 2003 Columns” on page 81) or click on the columns toolbar . .
Word 2007 Columns

- Select Page Layout on the Ribbon in Word 2007 and select Columns in the Page Setup group (See “Figure 67. Microsoft Word 2007 Columns” on page 81).

Word 2010 Columns

- Select Page Layout on the Ribbon in Word 2010 and select Columns from the Page Setup group (See “Figure 68. Microsoft Word 2010 Columns” on page 82).
Lists

Use Word’s list styles when creating bulleted or numbered lists to ensure that the structure represented by the list is transmitted to the PDF document. The list styles are found in Word’s Ribbon on the Home tag in the Paragraph Group.
Tables

Do not use tabs or spaces to create a table effect. Use Microsoft Word’s table editor.

- In order to have the cells in a table heading row automatically tagged as Table Headers (<TH> tags) when the Word document is converted to PDF, highlight the first row of the table.

- With the heading row selected, right mouse click and select the Table Properties option.

- With the Table Properties dialog displayed, select the Row tab and check the "Repeat as header row at the top of each page" to indicate the row is a header row, even if the table does not break across document pages (See “Figure 70. Microsoft Word 2010 Table Properties Dialog” on page 83).

![Figure 70. Microsoft Word 2010 Table Properties Dialog](image)

- If you don’t do this, or if you do not want the header row to be repeated in a multipage table, you will need to change the table cell tags in the header rows from <TD> to <TH> using the Acrobat X Pro Tags Panel or the Table Editor which is accessed from the Touch Up Read Order Tool.
Links

Allow Word to turn web addresses into hyperlinks. Word hyperlinks are automatically converted to PDF hyperlinks.

Use Word’s hyperlink dialog. On the Ribbon, select Insert Tab and the Hyperlink toolbar (keyboard shortcut Ctrl+K). See (See "Figure 71. Microsoft Word 2010 Columns" on page 84)

![Figure 71. Microsoft Word 2010 Columns](image)

Add Alternative Text

Alternative Text or Alt Text refers to text that can be read by a screen reader to describe graphics and images which people with visual disabilities cannot see. All Graphics and Images should be provided with alternative text descriptions. Avoid placing graphics too close to text. This can cause problems when converting to PDF. Place white space between text and graphics.

Word 2003

- Double Click on an image or right click and select the format picture dialog.
- Select the Web tab and enter the alternative text (See “Figure 72. Microsoft Word 2003 Web Tab for adding Alternative Text” on page 85).
Word 2007

- Right Click on an image and choose Size
- Select the Alt Text tab and enter the alternative text (See "Figure 73. Microsoft Word 2007 Alt Text for adding Alternative Text" on page 85). Screen capture of the Microsoft Word 2007 Size dialog with the Alt Text tab selected, for adding alternative text to an image.

Figure 72. Microsoft Word 2003 Web Tab for adding Alternative Text

Figure 73. Microsoft Word 2007 Alt Text for adding Alternative Text
Word 2010

- Right Click on an image and choose Size
- Select the Alt Text tab and enter the alternative text (See "Figure 74. Microsoft Word 2010 Alt Text dialog for adding Alternative Text" on page 86). Screen capture of the Microsoft Word 2007 Size dialog with the Alt Text tab selected, for adding alternative text to an image.

![Microsoft Word 2010 Alt Text dialog](image)

Figure 74. Microsoft Word 2010 Alt Text dialog for adding Alternative Text

Microsoft Word 2010 Accessibility Checker

Microsoft Word 2010 has a Check for Issues option that includes an accessibility checker that allows authors to check the document for content that persons with disabilities might find difficult to read. Checking the Word document for accessibility issues prior to converting it to a PDF file is a good practice that will identify problems that would pose accessibility challenges in the resulting PDF document.

To use the Microsoft Word 2010 Accessibility Checker do the following:

- Select the file tab in the Microsoft Word 2010 Ribbon
- Select the Info category and the Check for Issues button in the Prepare for Sharing section (See "Figure 75. Microsoft Word 2010 Check Accessibility Option" on page 87)
- From the drop down menu, select Check Accessibility
Figure 75. Microsoft Word 2010 Check Accessibility Option

- The Microsoft Word Accessibility Checker will display an Inspection Results panel that steps through the Word document, identifying errors and warnings and offering suggestions for fixing each issue.

Adobe Acrobat X PDFMaker

Once you have authored your Microsoft Word document with accessibility in mind, you are ready to convert it to an accessible PDF file. To generate an accessible PDF document directly from the Microsoft Word source, you should use the Adobe PDFMaker to convert the file to PDF.

PDFMaker is an Acrobat feature that operates within many business applications, such as Microsoft Office applications and Lotus Notes. When you install Acrobat, PDFMaker controls appear in the work area of the authoring application.

Using PDFMaker within an authoring application is a simple, one-click procedure. It involves clicking an Acrobat PDFMaker toolbar button or choosing a command on the Adobe PDF menu. It is not necessary to open Acrobat.

In Windows, Acrobat installs both an Acrobat PDFMaker toolbar and an Adobe PDF menu in many popular authoring applications. You can use either the toolbar buttons or the Adobe PDF menu to create PDFs, but the menu also provides access to conversion settings.

Note: For Microsoft Office 2007 applications such as Word, Excel, PowerPoint, and Access, the options for creating PDFs are available from the Acrobat ribbon (See “Figure 76. Microsoft Word 2007 Adobe Acrobat Ribbon and Group” on page 88).
Show or activate PDFMaker in Microsoft Word

If you don’t see the PDF toolbar buttons in Microsoft Word, you must show or activate the PDF toolbar. Use one of the following methods to show or activate PDFMaker.

For Office 2003 or earlier,

- Choose View > Toolbars > Acrobat PDFMaker 9.0

For Office 2007

Do the following:

- Click the Office button, and then click the Word Options button
- Click Add-Ins on the left side of the dialog box.
- Do one of the following:
  - If PDFMOutlook or Acrobat PDFMaker Office COM Addin is not listed, choose COM Add-Ins from the Manage pop-up menu and click Go.
  - If PDFMOutlook or Acrobat PDFMaker Office COM Addin is listed under Disabled Application Add-ins, select Disabled Items from the Manage pop-up menu and click Go.
  - Select PDFMOutlook or Acrobat PDFMaker Office COM Addin and click OK.
  - Restart the Office application.
**View PDFMaker conversion settings**

PDFMaker conversion settings determine what features of the Microsoft Word document will be included in the PDF and how they will be translated into the resulting PDF file.

Do one of the following:

- For Office 2003, choose Adobe PDF > Change Conversion Settings (See “Figure 77. Change PDFMaker Settings in Word 2003” on page 89). Screen capture of the Microsoft Word 2003 Adobe PDF menu, with the Change Conversion Settings option highlighted.

  ![Figure 77. Change PDFMaker Settings in Word 2003](image)

- For Office 2007 select the Acrobat tab from the ribbon, and click Preferences (See “Figure 78. Acrobat Preferences in Word 2007” on page 89). If you wish to revert to the original default settings, click Restore Defaults on the Settings tab.

  ![Figure 78. Acrobat Preferences in Word 2007](image)

- For Office 2010 select Acrobat tab from the ribbon, and click Preferences (See “Figure 70. Microsoft Word 2010 Table Properties Dialog” on page 83). If you wish to revert to the original default settings, click Restore Defaults on the Settings tab.
Figure 79. Acrobat Preferences in Word 2010

Settings Tab
The settings available for PDFMaker depend on the application in which you’re using PDFMaker (See "Figure 80. PDFMaker Settings Tab" on page 91).

- **Conversion Settings.** Specifies the standard by which the PDF will be optimized. When you choose an item in the menu, a description of that preset appears immediately below it.

- **View Adobe PDF Result.** Opens the converted document directly into Acrobat. (Exception: when you choose Convert To Adobe PDF And Email.)

- **Prompt For Adobe PDF File Name.** Lets you enter a custom filename for the resulting PDF. Deselect this option to save the file in the same folder as the source file, using the same name but with a .pdf extension.

- **Convert Document Information.** Adds document information from the Properties dialog box of the source file. This setting overrides the printer preferences and settings in the Advanced panel of the Adobe PDF Settings dialog box.

Note: The Advanced Settings button opens the Adobe PDF Settings dialog box, which contains many additional conversion options. These conversion settings apply to all Acrobat features that create PDFs, such as Acrobat Distiller, PDFMaker, and the Acrobat application itself.

- **Create PDF/A Compliant PDF File.** Creates the PDF so that it conforms to this ISO standard for long-term preservation of electronic documents. (In the Microsoft Publisher application alone, PDFMaker does not support the PDF/A standard.)

Note: When Conversion Settings are opened from within Word, Excel, or PowerPoint, this option specifies PDF/A 1-a:2005. When opened from within Microsoft Visio, Access, Microsoft Project, or AutoCAD, it specifies PDF/A 1-b:2005.

- **Attach Source File.** Includes the Word document that is being converted as an attachment to the resulting PDF.
• **Create Bookmarks.** Converts certain elements in original Office documents to PDF bookmarks: Word headings, Excel worksheet names, or PowerPoint titles. Selecting this option overrides any settings on the Bookmarks tab of the Conversion Settings dialog box.

• **Add Links.** Includes active links and hypertext in the PDF.

---

**Note:** If this option is deselected, but the recipient of the PDF has the Create Links From URLs preference selected, URLs in the PDF are still active.

• **Enable Accessibility And Reflow With Tagged Adobe PDF.** Embeds tags in the PDF (on by default).

---

![PDFMaker Settings Tab](image)

**Figure 80. PDFMaker Settings Tab**

**Security Tab**

The Security tab settings available for PDFMaker depend on the application in which you’re using PDFMaker (See “Figure 81. PDFMaker Security Tab” on page 92).

• **Require A Password To Open The Document.** When selected, makes the Document Open Password option available, where you enter a password that users must use to open the document.

• **Restrict Editing And Printing Of The Document.** When selected, makes the other Permissions options available.

• **Change Permissions Password.** Specifies a password you set that users must use in order to do any allowable printing or editing.

• **Printing Allowed.** Specifies whether users who use the Permissions Password can print the document and at what resolution.

• **Changes Allowed.** Specifies what kind of changes users who use the Permissions Password can make.

• **Enable Copying Of Text, Images, And Other Contents.** Prevents or allows users from copying from the PDF.
• **Enable Text Access For Screen Reader Devices For The Visually Impaired**. Prevents or allows screen reader devices to read text. (Selected by default.)

• **Enable Plaintext Metadata**. Specifies whether the search engine can read the document metadata. Available only when the PDF-compatibility is set to Acrobat 6.0 (PDF 1.5) or later.

Screen capture of the Acrobat PDF Maker dialog, with the Security tab selected and the Enable text access for screen reader devices option highlighted.

Figure 81. PDFMaker Security Tab

**Word Tab**

Use the Word Tab to control how certain features in Microsoft Word will be rendered in PDF (See “Figure 82. PDFMaker Word Tab” on page 93).

• **Convert Displayed Comments To Notes In Adobe PDF**. Changes any Word comment entries to PDF comments. If the currently open Word document contains comments, more options appear in the Comments list on this tab:
  
  • **Reviewer**. Lists the names of reviewers who have entered comments in the current Word document.
  
  • **Include**. When deselected, does not include the comments in the PDF.
  
  • **Notes Open**. Specifies whether the PDF comment windows automatically open or are closed for that reviewer's comments.
  
  • **Color**. Shows the color for that reviewer's comment icons. Clicking the color icon repeatedly cycles through a limited set of available colors.
  
  • **# Of Comments**. Shows the number of comments that the reviewer made.
  
  • **Convert Cross-References And Table Of Contents To Links (Word 2002 and 2003 only)**. Enables one-click navigation of these elements in the new PDF. This option is not available in Word 2007.
  
  • **Convert Footnote And Endnote Links**. Integrates these into the PDF.
• **Enable Advanced Tagging**. Integrates this into the PDF. Useful for Microsoft Word forms.

![PDFMaker Word Tab](image)

Figure 82. PDFMaker Word Tab

**Bookmarks Tab (Microsoft Word)**

The options you specify on this tab determine which items are converted into PDF bookmarks in the PDF (See “Figure 83. PDFMaker Bookmarks Tab” on page 94).

- **Note**: To include bookmarks in the conversion process, the Add Bookmarks To Adobe PDF option on the Settings tab must be selected. If you deselect that option, it overrides any options you select on this tab and no bookmarks are created.

- **Convert Word Headings To Bookmarks**. Selects all the headings in the Elements list for conversion to PDF bookmarks.

- **Convert Word Styles To Bookmarks**. Selects all the text styles in the Elements list for conversion to PDF bookmarks. (Unselected by default.)

- **Convert Word Bookmarks**. Converts any user-created Word bookmarks to PDF bookmarks.

- **Element list**. Specifies which Word headings and styles are converted to PDF bookmarks.

- **Element**. Lists the names of all available Word headings and styles. The icons for Headings and Styles indicate the element types.

- **Type**. Also indicates whether the element is a heading or style in the Word document.

- **Bookmark**. Displays X’s, indicating whether individual elements are converted to PDF bookmarks. Clicking an individual Bookmark option changes the selection status for that element.

- **Level**. Specifies where the element fits in the hierarchy structure of the PDF Bookmarks panel. Clicking an individual Level number opens a menu that you can use to change the value.
Note: When some but not all of the available Word headings and styles are selected for conversion to PDF bookmarks, the marker in the corresponding check boxes at the top of the tab change. If all elements of the type are selected, a check mark appears. If only some of the elements of that type are selected, a colored square appears. Otherwise, the check box is empty.

Screen capture of the Acrobat PDF Maker dialog with the Bookmarks tab selected.

Figure 83. PDFMaker Bookmarks Tab

Video Tab (Microsoft Word and PowerPoint)

The options you specify on this tab determine settings for multimedia files that are converted to FLV format and inserted into Word or PowerPoint files (See “Figure 84. PDFMaker Video Tab” on page 95).

- **Save Video In**. To save the converted video file in the same folder as the document, select Same As Document Folder. To save the converted video file in a different folder, select Use This Folder, and click Browse to locate and select a folder.

- **Video Quality**. A higher Video Quality setting results in a larger PDF file size.

- **Deinterlace**. Activates the video deinterlacing filter, which can improve video quality.

- **Encode Audio**. If unselected, the converted video file does not include audio. If selected, specify the data rate at which to encode the audio in the FLV file.
PDF Settings for Other Microsoft Office Applications

There are application specific options on the settings tab of the PDFMaker for other Microsoft Office applications.

Excel-specific options on the Settings tab

These options are specific to the Settings tab in the PDFMaker for the Microsoft Excel spreadsheet application.

- **Convert Comments**. Converts user-created Excel comments to notes and lists them in the Acrobat Comments panel.

- **Fit Worksheet To A Single Page**. Adjusts the size of each worksheet so that all the entries on that worksheet appear on the same page of the PDF.

- **Fit To Paper Width**. Adjusts the width of each worksheet so that all the columns on that worksheet appear on one page in the PDF.

- **Prompt For Selecting Excel Sheets**. Opens a dialog box at the beginning of the file conversion process. In this dialog box, you can specify which worksheets are included in the PDF and the order in which the sheets appear in the PDF.

PowerPoint-specific options on the Settings tab

These options are specific to the Settings tab in the PDFMaker for the Microsoft PowerPoint presentation application.

- **Convert Multimedia**. Converts any linked audio-video file to an FLV file and embeds it in the PDF.

- **Preserve Animation (PowerPoint 2002 and 2003 only)**. Converts any animation effects in the PowerPoint file to equivalent animations in the PDF. This option is not available in PowerPoint 2007.

- **Preserve Slide Transitions**. Converts PowerPoint slide transition effects to PDF transition effects.
• **Convert Hidden Slides To PDF Pages**. Converts any PowerPoint slides that are not seen in the usual playing of the presentation to PDF pages.

• **Convert Speaker Notes**. Converts any speaker notes for the PowerPoint presentation into Text notes in the PDF.

• **Use PowerPoint Printer Settings (PowerPoint 2002 and 2003 only)**. Uses the same printer settings in the PDF as in the original file. This option is not available in PowerPoint 2007.

### Convert the Word Document to Accessible PDF

Open the Microsoft Word file. Depending upon the version of Microsoft Word, there will be specific methods for converting the document to an accessible PDF file.

#### Microsoft Office 2003

There are two controls on the Microsoft Word 2003 interface for converting to accessible PDF (See “Figure 85. Convert to Adobe PDF in Word 2003” on page 96).

Do one of the following:

- Click the Convert To Adobe PDF button on the Acrobat PDFMaker toolbar
- Convert to Adobe PDF from the Adobe PDF menu

Figure 85. Convert to Adobe PDF in Word 2003

Do one of the following:

- Enter a filename and location for the PDF, and click Save.

#### Microsoft Office 2007

Do one of the following:

- Click the Create PDF button from the Create Adobe PDF Group on the Acrobat ribbon (See “Figure 86. Create Accessible PDF in Word 2007” on page 97). Screen capture of the Microsoft Word 2007 Acrobat ribbon, with the Create PDF button highlighted.
Figure 86. Create Accessible PDF in Word 2007

- Select Save as Adobe PDF from the Office button (See “Figure 87. Save as Accessible PDF in Word 2007” on page 97).

Figure 87. Save as Accessible PDF in Word 2007

- Enter a filename and location for the PDF, and click Save.

Microsoft Office 2010

Do one of the following:

- Click the Create PDF button from the Create Adobe PDF Group on the Acrobat ribbon (See "Figure 88. Create Accessible PDF in Word 2010" on page 97).

Figure 88. Create Accessible PDF in Word 2010

- Select the Save as Adobe PDF category from the File tab in Microsoft Word 2010 (See "Figure 89. Save as Accessible PDF in Word 2010" on page 98).
If the Word Document is a Form

If the Word document has been designed as a form and you want it to be a fillable PDF form, prepare the document as described. When you are ready to import it into PDF, do so from within Acrobat using the Form Wizard.

From Acrobat X Pro do the following:

• Select Forms > Start Form Wizard
• Check the box indicating "An existing electronic document"
• Select “Import a file from file system”
• Click the Browse button to locate the desired file
• Click Next

The document will be converted to PDF with Tags and fillable form fields. You may need to edit the results within Acrobat.

Check the Resulting PDF With Acrobat X Pro

Once you have converted the document, you will still need to check the results in Adobe Acrobat. To check the results, refer to the document Adobe® Acrobat® X Pro Accessibility Guide: Using the Accessibility Checker.

Depending upon the type of error, you may have to make adjustments in a particular location.

• Adjustments to the Conversion Settings
• Repairs You Make to the Source File
• Repairs You Make to the PDF File

Changes to the Conversion Settings

Some repairs will involve changes to the PDFMaker conversion settings. If, for example, your final check indicated that the PDF file was not tagged, you would need to verify that the Enable Accessibility and Reflow box was checked in the PDFMaker tabbed settings.
Repairs You Should Make in the Source File

Some repairs can be made on the PDF file, but they would be deleted the next time a PDF file was created from the same source. A good example is missing alternative text descriptions. You can certainly use the Touchup Reading Order Tool in Acrobat to add these to a PDF file, but if you want the change to last during updates to the file, it is better to add the alternative text in the Word document using the format picture dialog (See "Add Alternative Text" on page 84).

Repairs You Should Make in the PDF File

Some repairs must take place on the PDF file using Adobe Acrobat X.

Document Language

In some instances, even if the document language has been specified in the source file, the information about document language is not conveyed to the PDFMaker. Setting the language for an entire document in the Document Properties dialog box corrects all errors related to this option.

- Select File > Properties (Ctrl + D)
- In the Language drop down of the Reading Options section choose the appropriate language for the document.

Tab Order is Consistent with Structure Order

In some instances, even though the tags have been inherited from the source file, the Accessibility Checker will indicate that tab order is inconsistent with structure order. To correct this issue, do the following:

- Open the Pages icon or select View > Navigation Panels > Pages (ALT + VNP)
- Click on any page icon and type Cntrl + A (Command + A for the Mac OS) to select all the pages
- From the Options button on the pages panel select "Page Properties"
- In the Tab Order Panel, check “Use Document Structure”

Establish Table Headings for Tables

Table headers are not always properly defined after the conversion from Microsoft Word to PDF. Use the TouchUp Reading Order Table Editor to change table data cells that should be table headings to table headers or change the TD tags directly into TH tags within the tags panel.
Use Acrobat Action Wizards to Streamline Repetitive Tasks

When you apply one or more routine sets of commands to your files—such as setting the document language or verifying the tab order—you can save time and keystrokes by using an action wizard—a defined series of commands and instructions with specific settings and in a specific order that you apply in a single step. You can apply an action to a single document, to several documents, or to an entire collection of documents. You can even scan documents and combine several documents into a single PDF before running an action.

Acrobat provides some predefined action wizards. You can also create your own actions. You can access and manage the actions by choosing File > Action Wizard.

Adobe® Acrobat® X Pro also lets you export and import actions so that you can share actions with others.

---

**Note:** The actions interface and architecture replace the batch script mode available in the earlier versions of Adobe® Acrobat® X Pro. Most of your Acrobat 9 batch scripts can be imported as actions; some scripts require minor changes.
Using the Acrobat X Pro Accessibility Checker

Determine how easily persons with disabilities can access PDF documents with the Adobe Acrobat X Pro accessibility checker

The accessibility checking tools in Adobe Acrobat X Pro (Quick Check and Full Check) can help to identify areas of documents that may be in conflict with Adobe's interpretations of the accessibility guidelines referenced in the application and its documentation. However, these tools don't check documents against all accessibility criteria, including those in such referenced guidelines, and Adobe does not warrant that documents comply with any specific guidelines or regulations.

Accessibility Quick Check

Use Quick Check to check for document structure tags, searchable text, and appropriate security settings for accessibility. This method is often the best way to check for accessibility before attempting to use a PDF.

---

Note: The Accessibility Quick Check is also available for both Adobe Reader X and Adobe Acrobat X Pro.

- **Adobe Reader X Accessibility Quick Check.** In Adobe Reader X, the Accessibility Quick Check is run by selecting Edit > Accessibility > Quick Check from the Adobe Reader menu. The keyboard accelerator is Alt+E+Y+Q. The keyboard shortcut is Shift + Ctrl + 6.

- **Adobe Acrobat X Pro Accessibility Quick Check.** In Adobe Acrobat Pro X, you must first reveal the Accessibility Tool pane. If it is not already displayed, select View > Tools > Accessibility from the Adobe Acrobat X Pro menu. The keyboard accelerator is Alt+V+T+A.
  - With the Accessibility Tool Pane revealed, you can select the Quick Check panel (See "Figure 90. Acrobat X Pro Accessibility Quick Check Panel" on page 102).
  - The keyboard shortcut Shift + Ctrl + 6 runs the Accessibility Quick Check immediately without having to select the Quick Check panel from the Accessibility Tool pane.
Quick Check Results

The Quick Check will generate one of the following messages when reporting results to the user depending upon which accessibility features are present in the file.

- **This document has logical structure but it is not a Tagged PDF.** Some accessibility information may be missing. Quick Check has found an underlying document structure in the document, so Acrobat will use the available document structure to control the reading order, rather than analyzing the document itself. However, this untagged document structure might be incomplete or unreliable, so assistive software and the accessibility features in Acrobat (such as the Read Out Loud and the Save As Text features) may not read the page properly. If the reading order of the page seems to be wrong, select Override The Reading Order In Tagged Documents in the Reading panel of the Preferences dialog box.

- **This document is not structured, so the reading order may not be correct. Try different reading orders using the Reading Preferences panel.** Quick Check has found no underlying document structure that Acrobat can use for reading order. Acrobat will analyze the reading order of the document using the current analysis method set in the Reading Order preference, but this PDF might not be read correctly by screen readers. If the reading order seems wrong, select a different option for Reading Order in the Reading panel of the Preferences dialog box.

- **No accessibility problems were detected in this quick check. Choose the Full Check command to check more thoroughly.** Quick Check has found that the PDF contains searchable text, is tagged, has an underlying document structure, and has no security settings that prohibit access for screen readers. To check for other types of accessibility problems that may be present in the PDF, use Full Check.

- **This document's security settings prevent access by screen readers.** Quick Check has found that the PDF has security settings that interfere with screen readers' ability to extract text for conversion to speech. You may be able to use a screen reader with this document if your assistive technology product is registered with Adobe as a Trusted Agent. Contact your assistive technology product vendor.
• This document appears to contain no text. It may be a scanned image. Quick Check has found that the PDF contains no searchable text, probably because the document consists entirely of one or more scanned images. This means that screen readers, Read Out Loud, Reflow view, and most other accessibility features—which rely on text as input—will not work with this document.

**Full Check**

Use Full Check to perform a more thorough check for many characteristics of accessible PDFs, such as the use of fonts that can be mapped reliably to Unicode text.

Full Check checks a PDF for many of the characteristics of accessible PDFs. You can choose which kinds of accessibility problems to look for and how you want to view the results. To run the full Accessibility Check, do the following:

- In Adobe Acrobat Pro X, you must first reveal the Accessibility Tool pane. If it is not already displayed, select View > Tools > Accessibility from the Adobe Acrobat X Pro menu. The keyboard accelerator is Alt+V+T+A.

- With the Accessibility Tool Pane revealed, you can select the Full Check panel.

- Selecting the Full Check panel brings up the Accessibility Full Check dialog.

- You can save the results as an HTML file or as comments that are located where the accessibility problems are detected.

- Select a page range if you prefer to do a full check on individual sections of a document.

- Select an accessibility standard (Adobe PDF, Section 508 (U.S.), or W3C) from the Name menu, and then select the accessibility options to check for.

- Click Start Checking.

![Acrobat X Pro Accessibility Full Check Panel](image_url)
The results are displayed in the left panel, which also has helpful links and hints for repairing issues (See “Figure 93. Acrobat X Pro Accessibility Report” on page 104). If you created a report in step 2, the results are available in the selected folder. Clicking on the links highlights the problem areas in the document. The Accessibility Checker panel also provides hints for repair which you should follow.

Because the Full Check feature is unable to distinguish between essential and nonessential content types, some issues it reports don't affect readability. It's a good idea to review all issues to determine which ones require correction.
Accessibility Full Check Options

- **Create Accessibility Report**. Creates an HTML report of accessibility issues, which is opened in the navigation pane and saved in the location indicated by the Folder field.

- **Include Repair Hints In Accessibility Report**. Adds suggestions for fixing accessibility problems to the HTML report or comments.

- **Create Comments In Document**. Adds comments to the document that indicate accessibility problems. Delete all accessibility comments from the PDF after you repair the accessibility issues.

- **Page Range**. The range of pages to check.

- **Name**. The set of accessibility criteria to check. For the Section 508 and W3C guidelines, the options area includes a Browse button that links to the website for the respective guidelines. Select Adobe PDF to choose from options for the Adobe PDF accessibility standard

- **Alternative Descriptions Are Provided**. Checks for tagged figures that are missing alternate text.

- **Text Language Is Specified**. Checks for paragraphs that don't have a language specified for them. Setting the language for an entire document in the Document Properties dialog box corrects all errors related to this option.

- **Reliable Character Encoding Is Provided**. Checks for fonts that are inaccessible to screen readers and other assistive software. Fonts must contain enough information for Acrobat to correctly extract all the characters to text. If one or more fonts don't allow for the correct extraction of all the characters, the PDF is inaccessible.

- **All Content Is Contained In The Document Structure**. Checks for page elements that may have been overlooked during tagging. Adding these elements to the tag tree (if necessary) ensures that a screen reader can present the content to a user.

- **All Form Fields Have Descriptions**. Checks for form fields that are missing descriptions.

- **Tab Order Is Consistent With The Structure Order**. Checks whether tags properly reflect the document's structure.

- **List And Table Structure Is Correct**. Checks whether tags that have been generated for lists and tables meet the requirements of tagged PDF.

**Continue Checking Until All Issues are Addressed**

Repeat the process of running the Accessibility Checker and using familiar repair techniques or following the Hints for Repair until the Accessibility Checker indicates “The checker found no problems in this document” for the tests you have selected (See “Figure 94. A Successful Accessibility Check” on page 106).

**Note:** While the Accessibility Checker helps you evaluate the accessibility of your documents and helps identify areas that may be in conflict with Adobe's interpretations of the referenced guidelines, the Accessibility Checker does not check all accessibility guidelines and criteria, including those in such referenced guidelines, and Adobe does not warrant that your documents will comply with any specific guidelines or regulations. Please consult with your legal counsel for
guidance on compliance with the referenced guidelines or any other accessibility guidelines. Screen capture of an Adobe Acrobat dialog, indicating that no accessibility problems were found in the document.

Figure 94. A Successful Accessibility Check

Additional Validation Techniques

Of course, the best way to test the accessibility of a document is to attempt to use the document with the tools that your readers will use. However, even if you don’t have a screen reader or braille printer, you can still use any of several methods provided by Acrobat for checking the accessibility of a PDF file.

- Use Reflow view to quickly check reading order.
- Use Read Out Loud to experience the document as it will be experienced by readers who use this text-to-speech conversion tool.
- Save the document as accessible text and then read the saved text file in a word-processing application to experience the document as it will be experienced by readers who use a braille printer.
- Use the TouchUp Reading Order tool, Tags tab, and Content tab to examine the structure, reading order, and contents of a PDF in detail. A complete discussion of the TouchUp Reading Order tool can be found in the document Adobe® Acrobat® X Pro Accessibility Guide: PDF Accessibility Repair Workflow.
For more information
Solution details: www.adobe.com/accessibility/products/acrobat/
Program details: www.adobe.com/accessibility
Contact information: access@adobe.com